summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/nuspell/nuspell-3.0.0.ebuild14
1 files changed, 12 insertions, 2 deletions
diff --git a/app-text/nuspell/nuspell-3.0.0.ebuild b/app-text/nuspell/nuspell-3.0.0.ebuild
index b5874aeda40c..911f390e6d2f 100644
--- a/app-text/nuspell/nuspell-3.0.0.ebuild
+++ b/app-text/nuspell/nuspell-3.0.0.ebuild
@@ -9,10 +9,10 @@ DESCRIPTION="Spell checker library and CLI for complex natural languages"
HOMEPAGE="https://nuspell.github.io/ https://github.com/nuspell/nuspell"
SRC_URI="https://github.com/nuspell/nuspell/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-LICENSE="|| ( MPL-1.1 GPL-2+ LGPL-2.1+ ) LGPL-3+"
+LICENSE="test? ( || ( MPL-1.1 GPL-2+ LGPL-2.1+ ) ) LGPL-3+"
SLOT="0/3" # due to libnuspell.so.3
KEYWORDS="~amd64 ~x86"
-IUSE="doc"
+IUSE="doc test"
RDEPEND="dev-libs/icu"
DEPEND="${RDEPEND}
@@ -21,6 +21,16 @@ DEPEND="${RDEPEND}
DOCS=( CHANGELOG.md )
+RESTRICT="!test? ( test )"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTING=$(usex test)
+ )
+
+ cmake_src_configure
+}
+
pkg_postinst() {
einfo
einfo 'Nuspell needs language packs and/or dictionaries to be of use'