summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/libqtxdg/Manifest1
-rw-r--r--dev-libs/libqtxdg/libqtxdg-3.8.0.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-libs/libqtxdg/Manifest b/dev-libs/libqtxdg/Manifest
index 70d67e6602ab..b49d35dbca39 100644
--- a/dev-libs/libqtxdg/Manifest
+++ b/dev-libs/libqtxdg/Manifest
@@ -1 +1,2 @@
DIST libqtxdg-3.7.1.tar.xz 74832 BLAKE2B 92b0f47412e04fa3100f1045a0ceb69ee7787634ab02883958156b96e756aecae1e916fa9963ef072e1d78f337102b2bfb7a42a1dcd9481fd158dde73e57fcef SHA512 764fb953c5c5564a8f5e189f3fa867b82e1da215e0734d2fb995bb29ba163936a38cf68c6c812ff3c183b7ab4fce59d1189c68885b65f103accb5446e71682e7
+DIST libqtxdg-3.8.0.tar.xz 76044 BLAKE2B c49f1317c55ea09c4fe9aaea3e96851c4e5dcbc797e97a8db58dd34b35151e18c654327b71566b5578319dd7a01862627a52a02ce3840951e15fe01b57666dcc SHA512 e9e8d163fe1a60a2d03787ec3feef6ff6e89dfea4df7c0c7b3a72784992baf49ffeb352894d3cb8747ec0cd49576562f7dae3abbde932d13374f51bc77f14ea1
diff --git a/dev-libs/libqtxdg/libqtxdg-3.8.0.ebuild b/dev-libs/libqtxdg/libqtxdg-3.8.0.ebuild
new file mode 100644
index 000000000000..fb2f259b2831
--- /dev/null
+++ b/dev-libs/libqtxdg/libqtxdg-3.8.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake optfeature virtualx
+
+DESCRIPTION="Qt Implementation of XDG Standards"
+HOMEPAGE="https://lxqt.github.io/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/lxqt/${PN}.git"
+else
+ SRC_URI="https://github.com/lxqt/${PN}/releases/download/${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86"
+fi
+
+LICENSE="LGPL-2.1+ Nokia-Qt-LGPL-Exception-1.1"
+SLOT="0"
+IUSE="test"
+
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ >=dev-util/lxqt-build-tools-0.10.0
+ virtual/pkgconfig
+"
+RDEPEND="
+ >=dev-qt/qtcore-5.15:5
+ >=dev-qt/qtdbus-5.15:5
+ >=dev-qt/qtgui-5.15:5=
+ >=dev-qt/qtsvg-5.15:5
+ >=dev-qt/qtwidgets-5.15:5
+ >=dev-qt/qtxml-5.15:5
+ x11-misc/xdg-utils
+"
+DEPEND="${RDEPEND}
+ test? ( >=dev-qt/qttest-5.15:5 )
+"
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_TESTS=$(usex test)
+ )
+ cmake_src_configure
+}
+
+src_test() {
+ # Tests don't work with C
+ LC_ALL=en_US.utf8 virtx cmake_src_test
+}
+
+pkg_postinst() {
+ ! has_version lxqt-base/lxqt-meta && optfeature "features that require a terminal emulator" x11-terms/xterm
+}