summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/alembic/Manifest1
-rw-r--r--dev-python/alembic/alembic-0.7.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/alembic/Manifest b/dev-python/alembic/Manifest
index 08d72aa65b39..4f755939305d 100644
--- a/dev-python/alembic/Manifest
+++ b/dev-python/alembic/Manifest
@@ -1,3 +1,4 @@
+DIST alembic-0.7.4.tar.gz 604836 SHA256 550f10b2266f689778eced2fed899bfd05755737478454b97fb99385f2e780e5 SHA512 258d2f7fe046e7fd662fae0b68ba19988cc59fd1d0d8bb6e1b3b0ea133d076d649d6bc99933ac50be538d1c4d64062b2b2d259cb042d9bbddf7346d0283af383 WHIRLPOOL eaa17f8b0bd91ca8eb11292bc0be45443b43564b06ec1461c5d6b60dcbd3777c443c6a355164057334080a7dbf37f32cf591f176deb52afdb12d7ca79de4a766
DIST alembic-0.7.7.tar.gz 721855 SHA256 abdeded3f92766d30d2e00015f73573e23f96bcb38037fac199a75445e3e66c6 SHA512 5478987f37ca724e168fd4de4bd557ca3344aa0539ae25dd56fc05b855ec02004a1d8c3c14aa3f3715eaaa74431d1b25121810c3f197ba5def67afbbe41e62eb WHIRLPOOL e10e6930a559fa7a8e90dab83a08d3f9c2a252085d4732036e5e07c9b75329d851a64f6d68639eda88fdb136cfc43078434e23e5438551569ca55eb295a192a8
DIST alembic-0.8.2.tar.gz 931914 SHA256 a69d65a766801c40e921ca24ae358bf081a990f54b867bbdc3e2a73e975550be SHA512 530a30147af4add82c6162f69cf6742831c9909db49bd0ec7245e36db51f8cf008c4696b22df24a8df5ea44cbf3da1c02d1989fbbef349adda238af32e9a061b WHIRLPOOL 699eb29362a0276484cf64148dad6820cbaf41aef11b6f79165ac0aa6b2fbdc2643397bf947378b501acb94e8b9e04b0689903e4c6942b547eda93284f304c3e
DIST alembic-0.8.4.tar.gz 950696 SHA256 8507fc12ccc99321da2fa117dde4b5d8664ff5ef017df7ce5e7e5051901a624a SHA512 ef0c156d21b28dcabe1cb9249a0350fb12b489019240e46c37f2b070f04f86471afe0011c3df745f4d126a0477605f460cef63133cc28cb5ddf550f10627a7ab WHIRLPOOL 46dff4aeb8693314b708c5182d69e271422930fb1d4ffffee6d7f355f9845b8a19ce4385f6834fb83b35a316be6491c37d9ffd5e6824d349d753c1c12c04c0cb
diff --git a/dev-python/alembic/alembic-0.7.4.ebuild b/dev-python/alembic/alembic-0.7.4.ebuild
new file mode 100644
index 000000000000..26782e5fb0ed
--- /dev/null
+++ b/dev-python/alembic/alembic-0.7.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="database migrations tool, written by the author of SQLAlchemy"
+HOMEPAGE="https://bitbucket.org/zzzeek/alembic"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test doc"
+
+# requires.txt cites 'SQLAlchemy>=0.7.3' which is really both old and silly
+# because it shatters the testsuite. If 'someone' cares to adhere to correct form
+# and edit to -0.7.3, feel free, and then pick up the pieces.
+RDEPEND=">=dev-python/sqlalchemy-0.8.4[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# For test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # suite passes all if run from source. The residual fail & error are quite erroneous
+ rm tests/test_script_consumption.py
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} run_tests.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/. )
+
+ distutils-r1_python_install_all
+}