summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-libs/libutempter/Manifest1
-rw-r--r--sys-libs/libutempter/libutempter-1.1.6-r3.ebuild71
2 files changed, 0 insertions, 72 deletions
diff --git a/sys-libs/libutempter/Manifest b/sys-libs/libutempter/Manifest
index 051722e66bb2..837a2bf977ca 100644
--- a/sys-libs/libutempter/Manifest
+++ b/sys-libs/libutempter/Manifest
@@ -1,2 +1 @@
-DIST libutempter-1.1.6.tar.bz2 15705 BLAKE2B 147bf96990913019c35565507eb635ba60ff5ed67134805e9f146f8f70882615ff96d7b2e52b40fb73110905afb87893a72bdec4327d879e5bdc2ec1d39ff9f0 SHA512 6ada410b981d157ae20b578de8ce20997ec0446ec6de6859549b080aa65976fc9900d211600dab09dc3d0d109daabad0994a648b093b8781b442ff26ca17fede
DIST libutempter-1.2.1.tar.gz 17429 BLAKE2B 88ae0a03a8a614b960082ce4d4006ec4e3eb8148b319ae964ac3ba3f684f08f5dd670e693f25d52d04a280f7b2aed6d2894cbbc0e2db3f71ab68e6910ffb58d1 SHA512 d3a3bab7d2c2a68534c5ad41dd02bde849eb08df5dbb895a79b50b74d269c48c4cfcd12c4654941ccb7cdd43f486cfdc19148fa470870562f5cd324ce9782429
diff --git a/sys-libs/libutempter/libutempter-1.1.6-r3.ebuild b/sys-libs/libutempter/libutempter-1.1.6-r3.ebuild
deleted file mode 100644
index 326b59190559..000000000000
--- a/sys-libs/libutempter/libutempter-1.1.6-r3.ebuild
+++ /dev/null
@@ -1,71 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit flag-o-matic toolchain-funcs
-
-DESCRIPTION="Library that allows non-privileged apps to write utmp (login) info"
-HOMEPAGE="https://altlinux.org/index.php?module=sisyphus&package=libutempter"
-SRC_URI="ftp://ftp.altlinux.org/pub/people/ldv/${PN}/${P}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~m68k ~mips ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="static-libs elibc_FreeBSD"
-
-RDEPEND="
- !sys-apps/utempter
- acct-group/utmp
-"
-
-src_prepare() {
- default
-
- local args=(
- -e "/^libdir /s:/usr/lib:${EPREFIX}/usr/$(get_libdir):"
- -e '/^libexecdir /s:=.*:= $(libdir)/misc:'
- -e '/^CFLAGS = $(RPM_OPT_FLAGS)/d'
- -e 's:,-stats::'
- -e "/^includedir /s:/usr/include:${EPREFIX}/usr/include:"
- -e "/^mandir /s:=.*:= ${EPREFIX}/usr/share/man:"
- )
-
- if ! use static-libs ; then
- args+=(
- -e '/^STATICLIB/d'
- -e '/INSTALL.*STATICLIB/d'
- )
- fi
-
- sed -i "${args[@]}" Makefile || die
-}
-
-src_configure() {
- use elibc_FreeBSD && append-libs -lutil
- tc-export AR CC
-}
-
-src_compile() {
- emake LDLIBS="${LIBS}"
-}
-
-src_install() {
- default
-
- if ! use prefix ; then
- fowners root:utmp /usr/$(get_libdir)/misc/utempter/utempter
- fperms 2755 /usr/$(get_libdir)/misc/utempter/utempter
- fi
-
- dodir /usr/sbin
- dosym ../$(get_libdir)/misc/utempter/utempter /usr/sbin/utempter
-}
-
-pkg_postinst() {
- local path
- for path in "${EROOT}"/var/log/{w,u}tmp; do
- chown root:utmp "${path}"
- chmod 664 "${path}"
- done
-}