summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/sphinx/sphinx-1.7.5-r1.ebuild4
1 files changed, 1 insertions, 3 deletions
diff --git a/dev-python/sphinx/sphinx-1.7.5-r1.ebuild b/dev-python/sphinx/sphinx-1.7.5-r1.ebuild
index b39431a75c07..86a61f664a74 100644
--- a/dev-python/sphinx/sphinx-1.7.5-r1.ebuild
+++ b/dev-python/sphinx/sphinx-1.7.5-r1.ebuild
@@ -93,7 +93,5 @@ python_compile_all() {
python_test() {
mkdir -p "${BUILD_DIR}/sphinx_tempdir" || die
local -x SPHINX_TEST_TEMPDIR="${BUILD_DIR}/sphinx_tempdir"
- cp -r -l tests "${BUILD_DIR}"/ || die "Failed to copy tests"
- cp Makefile "${BUILD_DIR}"/ || die "Failed to copy Makefile"
- emake test
+ py.test -vv || die "Tests fail with ${EPYTHON}"
}