summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--x11-wm/muffin/Manifest1
-rw-r--r--x11-wm/muffin/muffin-2.8.4.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/x11-wm/muffin/Manifest b/x11-wm/muffin/Manifest
index 723998ff7d04..67cf0cddd240 100644
--- a/x11-wm/muffin/Manifest
+++ b/x11-wm/muffin/Manifest
@@ -1,2 +1,3 @@
DIST muffin-2.6.1.tar.gz 2702177 SHA256 0772ad6caace2f4570e7d3a0cbc8a6ef5f65be92c6a30cc95a59ed8bba6b5f74 SHA512 530e4bdabb780a16ddad237ab7aa1c2dbb688f6d1380dd0d18fa91b62675d36a2253415899d59957b7f34291c348b8a0e1a99214c3151c2fc2bc1d90f068d788 WHIRLPOOL d6832ac81051845432b21f66ff74499213f57dc66bea7d61f0a30c3a0aec54846911447451b8b54ccb0678ed00dfad90ce9cef9b2f2492d44e7c35adad2c5a24
DIST muffin-2.8.3.tar.gz 2714820 SHA256 1eb36a91491f2d0beb346aa78dff7ec0bc1bf936b730c6fb18f9ca4e3e5fd93d SHA512 f026a9f4a5a48e5f969cf0e0d2d71af2d463c88f34d3172da00e8d56912db15467619b8f8d09d2708731d56ee05ebce6457bf84a80910575e7c386e00b462c94 WHIRLPOOL a32534e9c98284265233e337c0e4943d411a703765c1073798bcd41fe52ee2c44153b0170e6c0d3ae7fc62febd4722da7991b24339797cadf5615b87d42dce46
+DIST muffin-2.8.4.tar.gz 2714879 SHA256 b0be7c338ac1c0015355d507d1d5dcba380d4b1749ab2bc4c57754be3e70734d SHA512 2966c52a6a4e57151479d6a6e7d8a54625f5ba833fd77451a8f4a0628a660c444dfc7bfbeb14b009f9666218db40d1e5cdd888eb3f90b52b7668720e455018b7 WHIRLPOOL cf3c331e2a72012fbfed827d7af9ae5479331cb6881cb3bf406441fdc0a1b02fdc9d88afd07baf6a10f3944663e1a11da130cae38c6c00fddd699a1cdd182845
diff --git a/x11-wm/muffin/muffin-2.8.4.ebuild b/x11-wm/muffin/muffin-2.8.4.ebuild
new file mode 100644
index 000000000000..01f70916ca1a
--- /dev/null
+++ b/x11-wm/muffin/muffin-2.8.4.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome2 python-any-r1
+
+DESCRIPTION="Compositing window manager forked from Mutter for use with Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/muffin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+introspection test xinerama"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ >=x11-libs/pango-1.2[X,introspection?]
+ >=x11-libs/cairo-1.14:=[X]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.9.12:3[X,introspection?]
+ >=dev-libs/glib-2.37.3:2[dbus]
+ >=gnome-extra/cinnamon-desktop-2.4:0=[introspection?]
+ >=gnome-base/gsettings-desktop-schemas-3.3.0[introspection?]
+ >=media-libs/clutter-1.14.3:1.0=[introspection?]
+ >=media-libs/cogl-1.13.3:1.0=[introspection?]
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/libXcomposite-0.3
+ >=x11-libs/startup-notification-0.7:=
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ virtual/opengl
+
+ gnome-extra/zenity
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ xinerama? ( x11-libs/libXinerama )
+"
+# needs gtk-doc, not just -am, for gtk-doc.make
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/expocity
+"
+
+src_prepare() {
+ epatch_user
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* *.txt doc/*.txt"
+ gnome2_src_configure \
+ --disable-static \
+ --enable-shape \
+ --enable-sm \
+ --enable-startup-notification \
+ --enable-xsync \
+ --enable-verbose-mode \
+ --with-libcanberra \
+ $(use_enable introspection) \
+ $(use_enable xinerama)
+}