summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/tomlkit/Manifest1
-rw-r--r--dev-python/tomlkit/tomlkit-0.10.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/tomlkit/Manifest b/dev-python/tomlkit/Manifest
index b82cca091295..94866175b5ce 100644
--- a/dev-python/tomlkit/Manifest
+++ b/dev-python/tomlkit/Manifest
@@ -1,2 +1,3 @@
DIST tomlkit-0.10.0.tar.gz 183499 BLAKE2B b9906dea2dd8867dca0208f3ce86b3d587f8504addfe25cf29f9164f50dc12d244010df53791ed01e0e7dd16e71ad77ce22c9ea7a37a6216880059c058f112e8 SHA512 05d03ae71a1d72ca0e03276f2b2530ca9fab7d6f366166a79839c66eaa00b55abb5f70a669ecb4d762dbbd655f10e4c4a373a7683cd781ae034d0910a0c3eccf
DIST tomlkit-0.10.1.tar.gz 183650 BLAKE2B 373ab028b60503cfb9983a969e97318a61004a8db1bafed32b775e2a26a5557f8493ea9026ac9dbeff707d198c2913c34bf25c7e424345bb6b5ea3aa211e3a4a SHA512 a5082b88a9b3832393d860258dd7584ed05788777d4c1dd98415bfb7c64acf8f77eaf18c3fcf824913d999ffa37b4481675b3fce9b8af8ef9c1be0712ad622a9
+DIST tomlkit-0.10.2.tar.gz 184537 BLAKE2B ab912e1c45d641e7c57f1121a6281ed0609c3ddf18c55eb887a67ac8a4df669a3e958e769a07f7ad456c80713337af4b892d4bb73671ce12e4b2fc4d09af0734 SHA512 e1d5353659f9a0f4ba2f6a0b82980f0b50b012e3b299c2c6b12aa8a63fc4772649bdc2b5a755c21acc46fe2d226241918fb09a4202cca596b6e9633be95e79d8
diff --git a/dev-python/tomlkit/tomlkit-0.10.2.ebuild b/dev-python/tomlkit/tomlkit-0.10.2.ebuild
new file mode 100644
index 000000000000..5e749d3f6d49
--- /dev/null
+++ b/dev-python/tomlkit/tomlkit-0.10.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Style preserving TOML library"
+HOMEPAGE="
+ https://github.com/sdispater/tomlkit/
+ https://pypi.org/project/tomlkit/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_configure() {
+ # use setup.py to avoid circular dep with poetry-core
+ cat > pyproject.toml <<-EOF || die
+ [build-system]
+ requires = ["setuptools", "wheel"]
+ build-backend = "setuptools.build_meta"
+ EOF
+}