summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-shells/fish/Manifest1
-rw-r--r--app-shells/fish/fish-2.7.1.ebuild80
2 files changed, 81 insertions, 0 deletions
diff --git a/app-shells/fish/Manifest b/app-shells/fish/Manifest
index bc6ffceef7db..5e816f0e78ce 100644
--- a/app-shells/fish/Manifest
+++ b/app-shells/fish/Manifest
@@ -1,2 +1,3 @@
DIST fish-2.6.0.tar.gz 3575346 BLAKE2B 8697dc6e50836d93d0ed22663e86016fec8e567cd4e129ea92008f52da6dd629bf11b70719beabe5c08bd3d7ba43d8017441f103d49a82c0faec3bc749e83764 SHA512 d4ded5ce24600e85673a7bb016e9dc36bce999b27f40e6b1ce0b9ca49a421be2d444d9d2b6f178f6eee963e59daa4a65df4c3de2a8086a610486f758fcfb0ed1
DIST fish-2.7.0.tar.gz 5760470 BLAKE2B 8b3b905b6118cbcb988cedb1e80bcaf0e69d3d27aa355421f11b4ae8d26f2bb8c8b05cf31b30035f2235a063d3385d0a999b73e505df906a35ca6f034410061e SHA512 1b43a8eb25c08d1bf2870d51e1c5328438ea05a21d9a122345d765190ded7a6e335b4e1d3b92a6f7f764190321f471e3cda7bf7e995521b4c98beffc745880e9
+DIST fish-2.7.1.tar.gz 5760550 BLAKE2B 71568a3a17f4222b05a314464a61fceb241409a7d42c46249486ca742ef0cf990c46d693bcc22521c18f58a558e6aab35759d0da6eb62ee6611a2a7946fe714d SHA512 45ee3453404c5d6c56d307b4cd19197de862f9f42d7fa06461acec56dea7146db5675cf6419dd5f72e939b3e4b1955d3761098df1de89a8cebe47645eb6f7a4b
diff --git a/app-shells/fish/fish-2.7.1.ebuild b/app-shells/fish/fish-2.7.1.ebuild
new file mode 100644
index 000000000000..c2a3ea0e6f17
--- /dev/null
+++ b/app-shells/fish/fish-2.7.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PV="${PV/_beta/b}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="fish is the Friendly Interactive SHell"
+HOMEPAGE="http://fishshell.com/"
+SRC_URI="https://github.com/${PN}-shell/${PN}-shell/releases/download/${MY_PV}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+[[ "${PV}" = *_* ]] || \
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="nls test"
+
+RDEPEND="
+ >=dev-libs/libpcre2-10.21[pcre32]
+ sys-libs/ncurses:0=
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/bc
+ nls? ( sys-devel/gettext )
+ test? ( dev-tcltk/expect )
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_configure() {
+ # Set things up for fish to be a default shell.
+ # It has to be in /bin in case /usr is unavailable.
+ # Also, all of its utilities have to be in /bin.
+ econf \
+ --bindir="${EPREFIX}"/bin \
+ --without-included-pcre2 \
+ $(use_with nls gettext)
+}
+
+src_compile() {
+ emake V=1
+}
+
+src_install() {
+ emake DESTDIR="${D}" V=1 install
+}
+
+src_test() {
+ emake V=1 test
+}
+
+pkg_postinst() {
+ elog "fish is now installed on your system."
+ elog "To run fish, type 'fish' in your terminal."
+ elog
+ elog "It is advised not to set fish as a default login shell."
+ elog "see bug #545830 for more details."
+ elog "Executing fish using ~/.bashrc is an alternative"
+ elog "see https://wiki.gentoo.org/wiki/Fish#Caveats for details"
+ elog
+ elog "To set your colors, run 'fish_config'"
+ elog "To scan your man pages for completions, run 'fish_update_completions'"
+ elog "To autocomplete command suggestions press Ctrl + F or right arrow key."
+ elog
+ elog "Please add a \"BROWSER\" variable to ${PN}'s environment pointing to the"
+ elog "browser of your choice to get acces to ${PN}'s help system:"
+ elog " BROWSER=\"/usr/bin/firefox\""
+ elog
+ elog "In order to get lzma and xz support for man-page completion please"
+ elog "emerge one of the following packages:"
+ elog " dev-python/backports-lzma"
+ elog " >=dev-lang/python-3.3"
+ elog
+ elog "If you have issues with cut'n'paste in X-terminals, install the"
+ elog "x11-misc/xsel package."
+ elog
+ elog "Have fun!"
+}