summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/iftop/files/iftop-1.0_pre4-fno-common.patch56
-rw-r--r--net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild3
-rw-r--r--net-analyzer/iftop/iftop-9999999.ebuild3
3 files changed, 60 insertions, 2 deletions
diff --git a/net-analyzer/iftop/files/iftop-1.0_pre4-fno-common.patch b/net-analyzer/iftop/files/iftop-1.0_pre4-fno-common.patch
new file mode 100644
index 000000000000..13e0f1058f40
--- /dev/null
+++ b/net-analyzer/iftop/files/iftop-1.0_pre4-fno-common.patch
@@ -0,0 +1,56 @@
+--- a/ui_common.c
++++ b/ui_common.c
+@@ -28,6 +28,13 @@
+ extern int history_pos;
+ extern int history_len;
+
++sorted_list_type screen_list;
++host_pair_line totals;
++int peaksent, peakrecv, peaktotal;
++history_type history_totals;
++hash_type* screen_hash;
++hash_type* service_hash;
++
+ /*
+ * Compare two screen lines based on bandwidth. Start comparing from the
+ * specified column
+--- a/ui_common.h
++++ b/ui_common.h
+@@ -33,12 +33,12 @@
+
+ extern options_t options;
+
+-sorted_list_type screen_list;
+-host_pair_line totals;
+-int peaksent, peakrecv, peaktotal;
++extern sorted_list_type screen_list;
++extern host_pair_line totals;
++extern int peaksent, peakrecv, peaktotal;
+ extern history_type history_totals;
+-hash_type* screen_hash;
+-hash_type* service_hash;
++extern hash_type* screen_hash;
++extern hash_type* service_hash;
+
+ void analyse_data(void);
+ void screen_list_init(void);
+--- a/ui.c
++++ b/ui.c
+@@ -253,7 +253,6 @@
+ }
+ }
+
+-extern history_type history_totals;
+
+
+ void ui_print() {
+--- a/iftop.c
++++ b/iftop.c
+@@ -66,7 +66,6 @@
+ extern options_t options;
+
+ hash_type* history;
+-history_type history_totals;
+ time_t last_timestamp;
+ time_t first_timestamp;
+ int history_pos = 0;
diff --git a/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild b/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild
index 8221ce61ddb3..3f9d11ed9b42 100644
--- a/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild
+++ b/net-analyzer/iftop/iftop-1.0_pre4-r4.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -26,6 +26,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.0_pre4-tsent-set-but-not-used.patch
"${FILESDIR}"/${PN}-1.0_pre4-ip6.arpa.patch
"${FILESDIR}"/${PN}-1.0_pre4-fix-MAC-formatting.patch
+ "${FILESDIR}"/${PN}-1.0_pre4-fno-common.patch
)
S="${WORKDIR}"/${P/_/}
diff --git a/net-analyzer/iftop/iftop-9999999.ebuild b/net-analyzer/iftop/iftop-9999999.ebuild
index 5e2de84db474..f67befd3bc29 100644
--- a/net-analyzer/iftop/iftop-9999999.ebuild
+++ b/net-analyzer/iftop/iftop-9999999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -25,6 +25,7 @@ PATCHES=(
"${FILESDIR}"/${PN}-1.0_pre4-configure.ac.patch
"${FILESDIR}"/${PN}-1.0_pre4-Makefile.am.patch
"${FILESDIR}"/${PN}-1.0_pre4-fix-MAC-formatting.patch
+ "${FILESDIR}"/${PN}-1.0_pre4-fno-common.patch
)
src_prepare() {