summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/jupyter-client/Manifest1
-rw-r--r--dev-python/jupyter-client/jupyter-client-8.2.0.ebuild49
2 files changed, 0 insertions, 50 deletions
diff --git a/dev-python/jupyter-client/Manifest b/dev-python/jupyter-client/Manifest
index 83278b480a0f..7e74dbad2c65 100644
--- a/dev-python/jupyter-client/Manifest
+++ b/dev-python/jupyter-client/Manifest
@@ -1,2 +1 @@
-DIST jupyter_client-8.2.0.tar.gz 335567 BLAKE2B e02f8813d12ec8ba0e15291dad04cfaeeb98ea524050a10d142d74af203e43aa1c2e22e7fd7b071c05831b3dd644985a42e38f59fee65f4570e5eb88bbc9fbb1 SHA512 1337c4f2d93d9cd2ae5e3d8f30a8e4af69dad6e09c97e949d9300df0668be4da91134c73da06eb417c10ff2c09fd7beb28699e7a17502ceee3453cb9323b4363
DIST jupyter_client-8.3.0.tar.gz 335973 BLAKE2B dd4b60994f5c2ba19d41f87dbbee1291e85595908e5b1fce77876d8164bc21bd65b257a65b333e2e3277fff66869d445fcd87c3c1a16166fa71da24d26b1e96e SHA512 2348cf67344cb9bbb9b020ef5570f5ca354c8acb00b9fb0d148b9419ec2efb922b1364ed3c2c2429ad66548af5dd90f232be1d56728ef09bd833312f13c07f77
diff --git a/dev-python/jupyter-client/jupyter-client-8.2.0.ebuild b/dev-python/jupyter-client/jupyter-client-8.2.0.ebuild
deleted file mode 100644
index 8caf4f3e6208..000000000000
--- a/dev-python/jupyter-client/jupyter-client-8.2.0.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{9..11} )
-PYTHON_REQ_USE="threads(+)"
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Jupyter protocol implementation and client libraries"
-HOMEPAGE="
- https://jupyter.org/
- https://github.com/jupyter/jupyter_client/
- https://pypi.org/project/jupyter-client/
-"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/jupyter-core-5.1[${PYTHON_USEDEP}]
- >=dev-python/python-dateutil-2.8.2[${PYTHON_USEDEP}]
- >=dev-python/pyzmq-23.0[${PYTHON_USEDEP}]
- >=dev-python/tornado-6.0[${PYTHON_USEDEP}]
- dev-python/traitlets[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- >=dev-python/importlib-metadata-4.8.3[${PYTHON_USEDEP}]
- ' 3.{8,9})
-"
-BDEPEND="
- test? (
- >=dev-python/ipykernel-6.14[${PYTHON_USEDEP}]
- >=dev-python/pytest-asyncio-0.18[${PYTHON_USEDEP}]
- >=dev-python/pytest-jupyter-0.4.1[${PYTHON_USEDEP}]
- dev-python/pytest-timeout[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-EPYTEST_DESELECT=(
- # TODO: times out
- tests/test_client.py::TestAsyncKernelClient::test_input_request
- # TODO
- tests/test_multikernelmanager.py::TestKernelManager::test_tcp_cinfo
-)