summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/bpython/Manifest1
-rw-r--r--dev-python/bpython/bpython-0.16.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/dev-python/bpython/Manifest b/dev-python/bpython/Manifest
index 463c4fc33f40..ab3ce25c4973 100644
--- a/dev-python/bpython/Manifest
+++ b/dev-python/bpython/Manifest
@@ -2,3 +2,4 @@ DIST bpython-0.13.2.tar.gz 158551 SHA256 a1870a78e44ed6ef54aa906c58234cb0d12011f
DIST bpython-0.14.2.tar.gz 184808 SHA256 d1f03c9b64a67219ef41aec258c95f192ade5fd187d48fe61b15c1f1d707e302 SHA512 aa6fb8a6fe08746c31783308423400bf2482c6401fc03a1cf1e95592b83946b49eb8df29ac274d0711e01e7b2dcad37c00a609b3b600c31774563d0638d67159 WHIRLPOOL fe6847da5bb0b5b72f9230d175dbe0812a010281bf6a022f87196f71426a37d116a3bf9292cdd20fcd465e56d9b7c3d975028d2bb3a07afacc5c87f3b4b3d0f6
DIST bpython-0.14.tar.gz 184430 SHA256 f7c9fc80fc5a4eb6a345a67815e31957c0c65c1bbdfc68cf99267cdc81a3d35b SHA512 1c43af30902ac01385a4f9d0af1f7531f190dea9ee0d43725d5a23d881874184beca1df9fc8f94f21110d99ca07a851861c56976199e9306515e2b00ca07f1f7 WHIRLPOOL 21dc44b48a0fb31d0c125fc203f90fe7750e81599353a51c215672ed82218fc3b4f544cdb530d6447d099e4eaa5983ad52b8f48e1e83bcf4799dad190af797eb
DIST bpython-0.15.tar.gz 198852 SHA256 3f4f7a32416371da2ee0774726875ce63d3f9fed8b58e5a9ad1580b33fd3cef7 SHA512 421a4c8cd7885b0cc73c38ca89bfdbe6535fc4f4575c42195b1b6a9ccdb68e8c3491ebefd7439241f322c3e4ae0a37679253ae8f63b41fc2cfc7fc2ab77b8867 WHIRLPOOL e6a83335d7ea2d099098fb3014aa212a14e71786c9d7e323cf0bba7223b98b9b4cffbeb214de53d9e00b03088304d41fedc37334266fa7e44ae4e905132c72c8
+DIST bpython-0.16.tar.gz 201898 SHA256 faf3ddf602bd8ad7f133011778966333b9dcefbc3100df27a200b648906f655f SHA512 1173d720aa679e4a6079c7febd36abbffa901604c99c6d1ce1e940a8fbcf8a4ba7bc526de0ef5290e3859a4384d1cd5cbef62fd9f056ddcb545b64d69d103a5b WHIRLPOOL 13aaebc84f9685cd617d5d88fcb48531020925412fa1a0ecda223907b441279bb7639938f06d21a216cf9c4137d3bd1c122f00dcfa8a88d03abba0471c2124c2
diff --git a/dev-python/bpython/bpython-0.16.ebuild b/dev-python/bpython/bpython-0.16.ebuild
new file mode 100644
index 000000000000..3b5ac833b523
--- /dev/null
+++ b/dev-python/bpython/bpython-0.16.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Syntax highlighting and autocompletion for the Python interpreter"
+HOMEPAGE="http://www.bpython-interpreter.org/ https://github.com/bpython/bpython https://pypi.python.org/pypi/bpython"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ >=dev-python/curtsies-0.2.10[${PYTHON_USEDEP}]
+ dev-python/greenlet[${PYTHON_USEDEP}]
+ dev-python/jedi[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/six-1.5[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ dev-python/watchdog[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+DOCS=( AUTHORS CHANGELOG sample.theme light.theme )
+
+# Req'd for clean build by each impl
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build -b html -c doc/sphinx/source/ \
+ doc/sphinx/source/ doc/sphinx/source/html || die "docs build failed"
+ fi
+}
+
+python_test() {
+ pushd build/lib > /dev/null
+ "${PYTHON}" -m unittest discover || die
+ popd > /dev/null
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/sphinx/source/html/. )
+ distutils-r1_python_install_all
+}