summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-irc/ircii/Manifest1
-rw-r--r--net-irc/ircii/ircii-20240111.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/net-irc/ircii/Manifest b/net-irc/ircii/Manifest
index f6f549b03553..b8b0fd9bd937 100644
--- a/net-irc/ircii/Manifest
+++ b/net-irc/ircii/Manifest
@@ -1,3 +1,4 @@
DIST ircii-20210314.tar.bz2 590626 BLAKE2B d9b785fd043f277ab7824b2161e9f8635f106802c502a905755fd7cfa1d34f8d7533e9bed7158f3ce0639787894c5f8f4ba4c96d628d3a50a34339f5a3d8466e SHA512 3dc3a4ddb000133907edb9b867ae7cb0b36488c875f5d4f56e70d7263cf042da6c429f60a8ed6cced89bca077aec42c9d992ea6b56b2ed8b4e91f125eeced310
DIST ircii-20221016.tar.bz2 578521 BLAKE2B 718ec9e4b5baf572a422d80932469c8c9fc24d24d2de3cebb062c30888084075b53bf386fe4b03db95631ee2c9b8e4f72a80d4bde2fb774132095dd65841a09f SHA512 36d6971810982515866fd510d5f70c4308424e66e395e3aeeb3270920daed5148b4b0f770eb5b9f15748d51f3392f48ddfd81f53edce8798076e90ffd4adc493
DIST ircii-20230930.tar.bz2 579155 BLAKE2B 2b13a523d2c4a27374f101e9d5557a61985ff9eda9b4224666770bff9600630e48e6e129f5a3389ad8bb74693773fb2c6e2eed437aa4bcb6aa2598acfd309c42 SHA512 6ac47d791331c1be5533aff849f0d0b0f2613ade077c8d750824fd6bc9dbf4ed1a7b75226c3beb93ef8c69f6fe8960500893741ee29c18e1b87c12d94e4c7a7f
+DIST ircii-20240111.tar.bz2 576700 BLAKE2B 785177e30dbe3b417aec9fb348574e4f539adcfef41534743c050d39aa0e0ba00ea52accc20b785a836f7496e66975549b85fa17a58c280d893f5c0927e1bb1b SHA512 4705b851671f89d1b4903539eb7e701913748138d460572bfeb7e6d565e760b9782aecb55d82c691f6f182864b12e78e13a7b5a1e3abcd535e5bc24c9815e1aa
diff --git a/net-irc/ircii/ircii-20240111.ebuild b/net-irc/ircii/ircii-20240111.ebuild
new file mode 100644
index 000000000000..fe5947fc8ff0
--- /dev/null
+++ b/net-irc/ircii/ircii-20240111.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs
+
+DESCRIPTION="An IRC and ICB client that runs under most UNIX platforms"
+SRC_URI="https://ircii.warped.com/${P}.tar.bz2
+ https://ircii.warped.com/old/${P}.tar.bz2
+ https://dev.gentoo.org/~bkohler/dist/${P}.tar.bz2"
+HOMEPAGE="http://eterna.com.au/ircii/"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+DEPEND="dev-libs/openssl:0=
+ sys-libs/ncurses:0=
+ virtual/libcrypt:=
+ virtual/libiconv"
+RDEPEND="${DEPEND}"
+
+PATCHES=( "${FILESDIR}/${PN}-manpage-path.patch" )
+DOCS=( ChangeLog INSTALL NEWS README doc/Copyright doc/crypto doc/VERSIONS
+ doc/ctcp )
+
+src_configure() {
+ tc-export CC
+ # --with-lto only appends -flto (so does --without-lto, sigh)
+ econf
+}
+
+src_install() {
+ # Still needed as of 20221016, otherwise man dirs don't exist
+ # at the right time.
+ emake -j1 DESTDIR="${D}" install
+ einstalldocs
+}