summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ruby/plist/Manifest1
-rw-r--r--dev-ruby/plist/plist-3.5.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-ruby/plist/Manifest b/dev-ruby/plist/Manifest
index 10c217f76f9f..a56d24dfff1c 100644
--- a/dev-ruby/plist/Manifest
+++ b/dev-ruby/plist/Manifest
@@ -1 +1,2 @@
DIST plist-3.4.0.tar.gz 36637 BLAKE2B 8ea6b11c9adca311d91cf22f7ca11cdcb3acbbb97e18a813de754acc4474183fdd7cdb569b8fe64da06170219ef2fdcabec1d2349399006254c7f399365d1f97 SHA512 01dc47b183b7dce1f20fad8d68d1bebbb6d509c62b77f41855305bf5aafd1abf7960d74f1cb9d2467648a166fbb1747bbdd57f228f10ac091d16ab1a7189525b
+DIST plist-3.5.0.tar.gz 36650 BLAKE2B 8f93f8ef2fdedd9da50c4bdf9c473d3b199cd828909ea1572b761bc4e8d0508e997a60737ea21c7fa96764787ecefd41aa0b0046f94d3f89de796a746a794e21 SHA512 b1c9ccd66db1e0d1ebef3931f6db0f57ace2a1bb417885da48e9658c66af28997b6675a8050db78fe0083f05afc91e1313cb823d79553288d7c0c4a3a9762920
diff --git a/dev-ruby/plist/plist-3.5.0.ebuild b/dev-ruby/plist/plist-3.5.0.ebuild
new file mode 100644
index 000000000000..3208cf05db0b
--- /dev/null
+++ b/dev-ruby/plist/plist-3.5.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+USE_RUBY="ruby24 ruby25 ruby26"
+
+RUBY_FAKEGEM_RECIPE_DOC="rdoc"
+RUBY_FAKEGEM_EXTRADOC="CHANGELOG.rdoc README.rdoc"
+
+RUBY_FAKEGEM_GEMSPEC="${PN}.gemspec"
+
+RUBY_FAKEGEM_BINWRAP=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="A library to manipulate Property List files, also known as plists"
+HOMEPAGE="https://github.com/patsplat/plist"
+SRC_URI="https://github.com/patsplat/plist/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE=""
+
+all_ruby_prepare() {
+ sed -i -e '/bundler/ s:^:#:' Rakefile || die
+ sed -i -e 's/git ls-files -z/find . -print0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}