summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-libs/webkit-gtk/files/2.30.3-fix-noGL-build.patch27
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-2.30.3.ebuild1
2 files changed, 28 insertions, 0 deletions
diff --git a/net-libs/webkit-gtk/files/2.30.3-fix-noGL-build.patch b/net-libs/webkit-gtk/files/2.30.3-fix-noGL-build.patch
new file mode 100644
index 000000000000..5e9f42677314
--- /dev/null
+++ b/net-libs/webkit-gtk/files/2.30.3-fix-noGL-build.patch
@@ -0,0 +1,27 @@
+From 25cf4db5575192fd306b7a74d496d1e10d8cfd3e Mon Sep 17 00:00:00 2001
+From: Mart Raudsepp <leio@gentoo.org>
+Date: Fri, 27 Nov 2020 22:47:30 +0200
+Subject: [PATCH] [X11] Fix build with disabled OpenGL
+
+The added PlatformDisplayX11::visual() method requires symbols from
+X11/Xutil.h, which wasn't added as an explicit include with only
+EGL headers indirectly pulled it in with standard build options.
+---
+ Source/WebCore/platform/graphics/x11/PlatformDisplayX11.cpp | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/Source/WebCore/platform/graphics/x11/PlatformDisplayX11.cpp b/Source/WebCore/platform/graphics/x11/PlatformDisplayX11.cpp
+index 8fe3d3e92c88..2b2805446aad 100644
+--- a/Source/WebCore/platform/graphics/x11/PlatformDisplayX11.cpp
++++ b/Source/WebCore/platform/graphics/x11/PlatformDisplayX11.cpp
+@@ -30,6 +30,7 @@
+
+ #if PLATFORM(X11)
+ #include <X11/Xlib.h>
++#include <X11/Xutil.h>
+ #include <X11/extensions/Xcomposite.h>
+ #if PLATFORM(GTK)
+ #include <X11/extensions/Xdamage.h>
+--
+2.20.1
+
diff --git a/net-libs/webkit-gtk/webkit-gtk-2.30.3.ebuild b/net-libs/webkit-gtk/webkit-gtk-2.30.3.ebuild
index c2c5d814610d..42baa21fdab9 100644
--- a/net-libs/webkit-gtk/webkit-gtk-2.30.3.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-2.30.3.ebuild
@@ -174,6 +174,7 @@ src_prepare() {
eapply "${FILESDIR}"/2.28.2-opengl-without-X-fixes.patch
eapply "${FILESDIR}"/2.28.2-non-jumbo-fix.patch
eapply "${FILESDIR}"/2.28.4-non-jumbo-fix2.patch
+ eapply "${FILESDIR}"/${PV}-fix-noGL-build.patch
cmake-utils_src_prepare
gnome2_src_prepare
}