summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-analyzer/flent/flent-1.0.1-r1.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-analyzer/flent/flent-1.0.1-r1.ebuild b/net-analyzer/flent/flent-1.0.1-r1.ebuild
new file mode 100644
index 000000000000..d90d41ace9b5
--- /dev/null
+++ b/net-analyzer/flent/flent-1.0.1-r1.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python{3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="The FLExible Network Tester"
+HOMEPAGE="https://flent.org/"
+SRC_URI="https://github.com/tohojo/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+qt5 +plots"
+
+RDEPEND="qt5? ( dev-python/PyQt5[${PYTHON_USEDEP}] )
+ plots? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
+ net-analyzer/netperf[demo]
+ net-misc/iperf
+ net-analyzer/fping"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"