summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/mkdocstrings-python/Manifest1
-rw-r--r--dev-python/mkdocstrings-python/mkdocstrings-python-1.1.2.ebuild40
2 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/mkdocstrings-python/Manifest b/dev-python/mkdocstrings-python/Manifest
index 8612ae736ffd..cd4c991f152b 100644
--- a/dev-python/mkdocstrings-python/Manifest
+++ b/dev-python/mkdocstrings-python/Manifest
@@ -1,2 +1,3 @@
DIST mkdocstrings-python-1.0.0.gh.tar.gz 126036 BLAKE2B aa5512d745e6da92a1fb622654d374170bf4a0d6957ed1425f6bfbc3dc96fb86125f4b04fcc7a7daf9a2e23dae3d42d3de6a94007b25fea6ca1eab234d9c07cf SHA512 0b22953d4074b46f407b9303e4b040f7c0ee47b1202a463bcda66079e371840be3775d0d2fb38b3398b6fdbe70fbb887593d6d0b0c6cd5f42ad76365582796f9
DIST mkdocstrings-python-1.1.0.gh.tar.gz 126744 BLAKE2B 02e70d2f6f63e7f9eaafa05a9a64a5aefb9122aa80815ffbd125d0bcc02813fe7d7c160696da49cae858ac11093f98dbf3588ffcc7d15ee360cb527484a56da6 SHA512 a9c0a165bd1d0d012e1ba4b2d6198edc6be0fbb28784dff07519fd232294f3932be6bbc9268181a0d1b2a275484cabb17719ccab33e659367a702641464ca4a9
+DIST mkdocstrings-python-1.1.2.gh.tar.gz 127162 BLAKE2B 1aa77a6846b8f4787091691c3862428400cf73e5b51f3d7a278e9d871136a3693d80a1fe79d6999dedefe66b0a14402e0d70c448f9260c1528024a56cf223c69 SHA512 40c8247bc6217e73c23555fb3de14ddc8995e1870c7bcee85c12c885b9710cd303da3cec22b4ae44ff5de050486958447d2d489d9739b9860c432e9e00fec0d7
diff --git a/dev-python/mkdocstrings-python/mkdocstrings-python-1.1.2.ebuild b/dev-python/mkdocstrings-python/mkdocstrings-python-1.1.2.ebuild
new file mode 100644
index 000000000000..b6da1191411b
--- /dev/null
+++ b/dev-python/mkdocstrings-python/mkdocstrings-python-1.1.2.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=pdm-backend
+
+inherit distutils-r1
+
+DESCRIPTION="Python handler for dev-python/mkdocstrings"
+HOMEPAGE="
+ https://mkdocstrings.github.io/python/
+ https://github.com/mkdocstrings/python/
+ https://pypi.org/project/mkdocstrings-python/
+"
+# Tests need files absent from the PyPI tarballs
+SRC_URI="
+ https://github.com/mkdocstrings/python/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S="${WORKDIR}/python-${PV}"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv"
+
+RDEPEND="
+ dev-python/griffe[${PYTHON_USEDEP}]
+ dev-python/mkdocstrings[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mkdocs-material[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export PDM_BUILD_SCM_VERSION=${PV}