summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/configshell-fb/Manifest1
-rw-r--r--dev-python/configshell-fb/configshell-fb-1.1.22.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/configshell-fb/Manifest b/dev-python/configshell-fb/Manifest
index 2da50f79f0e3..45d8e43dafe2 100644
--- a/dev-python/configshell-fb/Manifest
+++ b/dev-python/configshell-fb/Manifest
@@ -1 +1,2 @@
DIST configshell-fb-1.1.21.tar.gz 36929 SHA256 f96daac404e4483e9f3113fbd675264d14dce1db83155b8537c94c4267e9b740 SHA512 4cf353da513b0e6863a2f93086d98254c2a74596f52ea7fe8823dda7bec4c4c247b54ec277348264f6d33b576a581c7617da01891997e83619f84e9a4def3e57 WHIRLPOOL b7de33bde6891b40950b796fbf9ddbe15f7907860d5cc42097cc88f892989e0cb8f8b5f3ff3d2bf12b138e295385d048e154487356fb26352ef95572aa5ac923
+DIST configshell-fb-1.1.22.tar.gz 34383 SHA256 a20b95791cdba6f7587869f4fa4337e8e4effbdec102ac6f7de349fe3b5bc612 SHA512 be6fa988ec42014da7e33c5610c2075c04ac7024e64f1c5665a0178d1390356505d69f93d58cc43b602bd26cb4ca28d085b55feafbce90a5dfb57ab26438eea8 WHIRLPOOL 2d6f0767600728c6803c61b63b4910ad56b349cc62cc74b130fb4e0f94440ec808983ee6b4e9470c00393c45bc95f10033124ef06a6dab573c47477018bf66fd
diff --git a/dev-python/configshell-fb/configshell-fb-1.1.22.ebuild b/dev-python/configshell-fb/configshell-fb-1.1.22.ebuild
new file mode 100644
index 000000000000..2c2eba12f1f6
--- /dev/null
+++ b/dev-python/configshell-fb/configshell-fb-1.1.22.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1 versionator
+
+MY_PV=$(replace_version_separator 2 '.fb' ${PV})
+
+DESCRIPTION="A Python library for building configuration shells"
+HOMEPAGE="https://github.com/open-iscsi/configshell-fb"
+SRC_URI="https://github.com/open-iscsi/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/pyparsing[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/urwid[${PYTHON_USEDEP}]
+ !dev-python/configshell"
+
+S=${WORKDIR}/${PN}-${MY_PV}