summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--media-libs/libopenraw/files/libopenraw-0.3.7-slibtool.patch16
-rw-r--r--media-libs/libopenraw/libopenraw-0.3.7.ebuild11
2 files changed, 26 insertions, 1 deletions
diff --git a/media-libs/libopenraw/files/libopenraw-0.3.7-slibtool.patch b/media-libs/libopenraw/files/libopenraw-0.3.7-slibtool.patch
new file mode 100644
index 000000000000..1109a332402e
--- /dev/null
+++ b/media-libs/libopenraw/files/libopenraw-0.3.7-slibtool.patch
@@ -0,0 +1,16 @@
+https://bugs.gentoo.org/913723
+https://gitlab.freedesktop.org/libopenraw/libopenraw/-/commit/eb873c75b09074d710e3f105b9c988a28058db53
+
+--- a/lib/Makefile.am
++++ b/lib/Makefile.am
+@@ -118,10 +118,8 @@ clean-local:
+ CARGO_TARGET_DIR=$(CARGO_TARGET_DIR) cargo clean $(CARGO_VERBOSE) $(CARGO_RELEASE_ARGS)
+ rm -f $(CARGO_TARGET_DIR)/.rustc_info.json
+
+-# The use of --all-static is necesary for the RUST_LIB
+ libopenraw_la_LDFLAGS = \
+ -version-info @LIBOPENRAW_VERSION_INFO@ \
+- --all-static \
+ -lpthread -ldl
+ libopenraw_la_LIBADD = -ljpeg $(RUST_LIB) libopenraw_internals.la
+ libopenraw_la_SOURCES = \
diff --git a/media-libs/libopenraw/libopenraw-0.3.7.ebuild b/media-libs/libopenraw/libopenraw-0.3.7.ebuild
index 51dac50a7387..f31d6215774d 100644
--- a/media-libs/libopenraw/libopenraw-0.3.7.ebuild
+++ b/media-libs/libopenraw/libopenraw-0.3.7.ebuild
@@ -4,7 +4,7 @@
EAPI=8
CRATES=" "
-inherit cargo gnome2-utils
+inherit autotools cargo gnome2-utils
DESCRIPTION="RAW image formats decoding library"
HOMEPAGE="https://libopenraw.freedesktop.org/"
@@ -34,6 +34,15 @@ BDEPEND="
test? ( net-misc/curl )
"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.7-slibtool.patch #913723
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
src_configure() {
econf \
--with-boost="${EPREFIX}"/usr \