summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--net-nds/openldap/openldap-2.6.4-r1.ebuild8
1 files changed, 8 insertions, 0 deletions
diff --git a/net-nds/openldap/openldap-2.6.4-r1.ebuild b/net-nds/openldap/openldap-2.6.4-r1.ebuild
index 56617abc986c..51316d05feb1 100644
--- a/net-nds/openldap/openldap-2.6.4-r1.ebuild
+++ b/net-nds/openldap/openldap-2.6.4-r1.ebuild
@@ -642,6 +642,7 @@ multilib_src_compile() {
$(tc-getCC) -shared \
-I"${BUILD_DIR}"/include \
-I../../../include \
+ ${CPPFLAGS} \
${CFLAGS} \
-fPIC \
${LDFLAGS} \
@@ -656,6 +657,13 @@ multilib_src_test() {
cd tests || die
pwd
+ # Increase various test timeouts/delays, bug #894012
+ # We can't just double everything as there's a cumulative effect.
+ export SLEEP0=2 # originally 1
+ export SLEEP1=10 # originally 7
+ export SLEEP2=20 # originally 15
+ export TIMEOUT=16 # originally 8
+
# emake test => runs only lloadd & mdb, in serial; skips ldif,sql,wt,regression
# emake partests => runs ALL of the tests in parallel
# wt/WiredTiger is not supported in Gentoo