summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-4.0.1.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index 88b474b837f9..3ea2ca718d01 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -2,3 +2,4 @@ DIST pytest-3.2.2.tar.gz 786396 BLAKE2B e669da930890e902b0323ec3a6685080ddd889e7
DIST pytest-3.4.2.tar.gz 812719 BLAKE2B 96623d6cdea4bd79778175c18c949938505f1862010f700f9a8cb85f445910381af391a5b69e664fbbfc254bf46502c798c72026772070236a0a3bca7aeeb3d6 SHA512 787065ab76d4482799bb2da9f024c9c383e68cc1cc01f3b80f6ed9444ca6383d20953615696ed4dd01668777b094cf5002b23c4ce51828879dcf8ebf2170c71b
DIST pytest-3.6.3.tar.gz 830949 BLAKE2B 4c0df5d157b8bb0ac6261a793aac2a8074c869b1a7cbda3eda600c79648b3722eaf2a57514c1fece60e0aac324b8ed09e8e889dda268619204e9e1f1637e1c9b SHA512 e18d8e972cb1b05b037b9441eea5981ce036d8e2c2bab80f6e50f283df9bd08740296133990424cf78449f6d3d2fbd1d59709770aa972af99fe061583f2d79a7
DIST pytest-3.8.2.tar.gz 869668 BLAKE2B 91d75481e4ef36ab06654b340751a33a96b9f6187cdfc65694973e2d4d7ddc5806fe673c87f0aa442c6c657a953b36c22d288eee8f61cc002be4be803bc98111 SHA512 5420de07ff741f64bcb7fce7bf3b5097cf63be2539c2e694c168bd824ba468ca87cb17be801b72b972ab417da98d1b5473f319afd642bf5c6c0270e3a697d016
+DIST pytest-4.0.1.tar.gz 903708 BLAKE2B b770ccd3d4bf64410f9accd6e7afc3e27be9b90f1f7bbc6f4ce2498ec6939d1329da8cf5dde85eeeeb4e8f158ee21c733f6cf41906a0aa93cf86cd30516a92fe SHA512 55513e9da61037b7381892d1d60a6b40d4d06ad3d7ab1e186b3bb88ed6a8469c7b30779880906628c74162b1f4664566c27388562e5f95342cf2af63b323e1d1
diff --git a/dev-python/pytest/pytest-4.0.1.ebuild b/dev-python/pytest/pytest-4.0.1.ebuild
new file mode 100644
index 000000000000..e626c60a79d4
--- /dev/null
+++ b/dev-python/pytest/pytest-4.0.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="http://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc64 ~sparc ~x86 ~amd64-fbsd ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+# doc apparently requires sphinxcontrib_trio, not yet packaged
+IUSE="test" # doc
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.5.0"
+
+# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
+# support, which only came in py3.6.
+RDEPEND="
+ >=dev-python/atomicwrites-1.0[${PYTHON_USEDEP}]
+ >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/pathlib2[${PYTHON_USEDEP}]' python2_7 python3_{4,5} )
+ >=dev-python/pluggy-0.7[${PYTHON_USEDEP}]
+ >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-40[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]"
+
+# doc? (
+# dev-python/pyyaml[${PYTHON_USEDEP}]
+# dev-python/sphinx[${PYTHON_USEDEP}]
+# )"
+
+# flake & pytest-capturelog cause a number of tests to fail
+DEPEND="${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ >=dev-python/pytest-xdist-1.22.2[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' -2)
+ dev-python/requests[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ !!dev-python/pytest-capturelog
+ )"
+
+python_prepare_all() {
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+
+ # Something in the ebuild environment causes this to hang/error.
+ # https://bugs.gentoo.org/598442
+ rm testing/test_pdb.py || die
+
+ # those tests appear to hang with python3.5+; TODO: investigate why
+ sed -i -e 's:test_runtest_location_shown_before_test_starts:_&:' \
+ testing/test_terminal.py || die
+ sed -i -e 's:test_trial_pdb:_&:' testing/test_unittest.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${PYTHON}" "${BUILD_DIR}"/lib/pytest.py --lsof -rfsxX \
+ -vv testing || die "tests failed with ${EPYTHON}"
+}
+
+#python_compile_all() {
+# use doc && emake -C doc/en html
+#}
+#
+#python_install_all() {
+# use doc && HTML_DOCS=( doc/en/_build/html/. )
+# distutils-r1_python_install_all
+#}