summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/wstools/Manifest1
-rw-r--r--dev-python/wstools/wstools-0.4.5.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/wstools/Manifest b/dev-python/wstools/Manifest
index 1f470c0510c8..a5dfe5936e2c 100644
--- a/dev-python/wstools/Manifest
+++ b/dev-python/wstools/Manifest
@@ -1,2 +1,3 @@
DIST wstools-0.4.3.tar.gz 148878 SHA256 578b53e98bc8dadf5a55dfd1f559fd9b37a594609f1883f23e8646d2d30336f8 SHA512 e735e2ae63aa410a56c79bef0bec7196393bb8f52d8521001d298b6290a75662f7262b6cd3c3238eeaf33263036cc6dabf8435ebd2fd1c98481cea524d0382ed WHIRLPOOL fa5ca24db23d99337cb08f3317327f6076f230c787477275e54d2322931d4e86831357043df6e8c12f3a62bac95eda13f614120588e9d3265ba40251c68b2881
DIST wstools-0.4.4.tar.gz 53813 SHA256 000cca12538e30547d4655ce84ef4977dabfc65a7b27d28e319695b78aa40126 SHA512 a9a31f3e31ab4d06d7ad151a5df4a710fecba7cf5da533b0f7b84fe7c1c49d4837dd8304cbbe17080d621521fe90ebe78a571d6e76dba8ca75e84b6e391ab1ce WHIRLPOOL 8dad867b613b821126e8068fc49fb5cabc6ace52344dac24c2869169d954e0cf42c7ded1e31900d585d1f83d5c8e187b5c5f0ae5a1a899e60ff55aa575571151
+DIST wstools-0.4.5.tar.gz 201047 SHA256 499760d87d9bb62fb937669bb9acb2de8a6393dcce3c5fbd3bc693b4a7bdd4ba SHA512 24779bc2c2f3e32a515bc5690038e3f8e487fd45c1b7822d587e1bfd0bda660b837e3d5cbf8248459e06d7606e6d1c404dcee4de35b1f0d353bd5213e197d83a WHIRLPOOL 80341b7e7756cd750ab97983b9175ed6ad7e482c9d3ca5d2a34a3d9166ec68bca107fbf741f4b18379e3b958b4b1872c32ce3274a859bfbc58c16735f749c652
diff --git a/dev-python/wstools/wstools-0.4.5.ebuild b/dev-python/wstools/wstools-0.4.5.ebuild
new file mode 100644
index 000000000000..18f926d2177a
--- /dev/null
+++ b/dev-python/wstools/wstools-0.4.5.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+PYTHON_REQ_USE="xml(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="WSDL parsing services package for Web Services for Python"
+HOMEPAGE="https://github.com/kiorky/wstools https://pypi.python.org/pypi/wstools"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/autopep8[${PYTHON_USEDEP}]
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/pep8[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cache[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ dev-python/pytest-pep8[${PYTHON_USEDEP}]
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/pip[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"