summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-editors/gedit/Manifest1
-rw-r--r--app-editors/gedit/gedit-3.20.2.ebuild101
-rw-r--r--profiles/arch/alpha/package.use.mask4
-rw-r--r--profiles/arch/arm/package.use.mask4
-rw-r--r--profiles/arch/ia64/package.use.mask4
-rw-r--r--profiles/arch/powerpc/ppc32/package.use.mask4
-rw-r--r--profiles/arch/powerpc/ppc64/package.use.mask4
-rw-r--r--profiles/arch/sparc/package.use.mask4
8 files changed, 126 insertions, 0 deletions
diff --git a/app-editors/gedit/Manifest b/app-editors/gedit/Manifest
index c93269be0c8a..7b899432b606 100644
--- a/app-editors/gedit/Manifest
+++ b/app-editors/gedit/Manifest
@@ -1,3 +1,4 @@
DIST gedit-3.16.4.tar.xz 2925984 SHA256 210937ea9143d8a6c9580a7ab11acf60d478f516d591ace6c8384fb085fb4cc0 SHA512 6320e11f6387b317789f6af4bdbb54350af89bd00c1443b26e68afdacf87c672ca74caf50c9ead80f4395a826d07a8da640e5d5ae89f71bccf75da683f420a81 WHIRLPOOL 057a7ecf22d12fa4899d20e3e365000bfe5c39873edc1331a75c1a061a5ce601b69d5ffaec1685cf0751ab0d7feff68e4d8be024654afdf90a6c08d0193aa2e9
DIST gedit-3.18.2.tar.xz 2915772 SHA256 856e451aec29ee45980011de57cadfe89c3cbc53968f6cc865f8efe0bd0d49b1 SHA512 e81382b74749c4592565bab25d47784a3206e033e6b0e5d5a557403590dafd130e41b31bcecc820a3d9823a48f8e94907bc9bb0335121e369abaca1360a95b30 WHIRLPOOL 87b40323caa707a4ce68d5efc299075883a1fc01e1def15f9052802bccae9075c3aa8c50d36062bb96060421008c510d3c0600fd359950a06ae651e3b56553e5
DIST gedit-3.18.3.tar.xz 2933132 SHA256 6762ac0d793b0f754a2da5f88739d04fa39daa7491c5c46401d24bcef76c32e7 SHA512 8866bc0958dfcf59e5eac0f3c39f2b5f252ffac78a25551968f539f73ebc25cc792ded93899c066339e9b6927f86d6e5ac583df9b9c4d7f0b07d1cc7683e7eb2 WHIRLPOOL fc60b4d251519057eab978a454a2eb0f6741fd097b58f1ac9614413bdab93e15a5f83132ed14f53ae6a6a49a94e9b78a8acce855d229a8f964fefae044a796e8
+DIST gedit-3.20.2.tar.xz 3135004 SHA256 32a1276a71a0d4a5af4e20a87bc273170ba8e075fc1ca7f51c8d3a6c150463f8 SHA512 3a224a5e0789760f0840b902fd7fa3c1d56b8100e3c502cf9a1c26336cc922192ba7bb37c1c7fd2069c71ccd0483fb692439d73fcb464117f520ec0d140aaf6d WHIRLPOOL 2128fda00474c197b4a85478cd676ae99d929871635b44d2641ffc5c58b47aceb943906c6a8ee3fcd1bbd309e217090a44ea4d83530adf6daab055f410c0796c
diff --git a/app-editors/gedit/gedit-3.20.2.ebuild b/app-editors/gedit/gedit-3.20.2.ebuild
new file mode 100644
index 000000000000..5a6cd5cf40b8
--- /dev/null
+++ b/app-editors/gedit/gedit-3.20.2.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+GNOME2_LA_PUNT="yes" # plugins are dlopened
+PYTHON_COMPAT=( python3_{3,4,5} )
+VALA_MIN_API_VERSION="0.26"
+VALA_USE_DEPEND="vapigen"
+
+inherit eutils gnome2 multilib python-r1 vala virtualx
+
+DESCRIPTION="A text editor for the GNOME desktop"
+HOMEPAGE="https://wiki.gnome.org/Apps/Gedit"
+
+LICENSE="GPL-2+ CC-BY-SA-3.0"
+SLOT="0"
+
+IUSE="+introspection +python spell vala"
+# python-single-r1 would request disabling PYTHON_TARGETS on libpeas
+# we need to fix that
+REQUIRED_USE="
+ python? ( introspection )
+ python? ( ^^ ( $(python_gen_useflags '*') ) )
+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~ia64-linux ~x86-linux"
+
+# X libs are not needed for OSX (aqua)
+COMMON_DEPEND="
+ >=dev-libs/libxml2-2.5.0:2
+ >=dev-libs/glib-2.44:2[dbus]
+ >=x11-libs/gtk+-3.19.0:3[introspection?]
+ >=x11-libs/gtksourceview-3.19.4:3.0[introspection?]
+ >=dev-libs/libpeas-1.14.1[gtk]
+
+ gnome-base/gsettings-desktop-schemas
+ gnome-base/gvfs
+
+ x11-libs/libX11
+
+ net-libs/libsoup:2.4
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.3:= )
+ python? (
+ ${PYTHON_DEPS}
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ >=dev-python/pygobject-3:3[cairo,${PYTHON_USEDEP}]
+ dev-libs/libpeas[${PYTHON_USEDEP}] )
+ spell? ( >=app-text/gspell-0.2.5:0= )
+"
+RDEPEND="${COMMON_DEPEND}
+ x11-themes/adwaita-icon-theme
+"
+DEPEND="${COMMON_DEPEND}
+ ${vala_depend}
+ app-text/docbook-xml-dtd:4.1.2
+ app-text/yelp-tools
+ dev-libs/libxml2:2
+ >=dev-util/gtk-doc-am-1
+ >=dev-util/intltool-0.50.1
+ dev-util/itstool
+ >=sys-devel/gettext-0.18
+ virtual/pkgconfig
+"
+# yelp-tools, gnome-common needed to eautoreconf
+
+pkg_setup() {
+ use python && [[ ${MERGE_TYPE} != binary ]] && python_setup
+}
+
+src_prepare() {
+ vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog MAINTAINERS NEWS README"
+
+ gnome2_src_configure \
+ --disable-deprecations \
+ --enable-updater \
+ --enable-gvfs-metadata \
+ $(use_enable introspection) \
+ $(use_enable spell) \
+ $(use_enable python) \
+ $(use_enable vala)
+}
+
+src_test() {
+ "${EROOT}${GLIB_COMPILE_SCHEMAS}" --allow-any-name "${S}/data" || die
+ GSETTINGS_SCHEMA_DIR="${S}/data" virtx emake check
+}
+
+src_install() {
+ local args=()
+ # manually set pyoverridesdir due to bug #524018 and AM_PATH_PYTHON limitations
+ use python && args+=( pyoverridesdir="$(python_get_sitedir)/gi/overrides" )
+
+ gnome2_src_install "${args[@]}"
+}
diff --git a/profiles/arch/alpha/package.use.mask b/profiles/arch/alpha/package.use.mask
index 438a3bb48077..e4776f5d2da4 100644
--- a/profiles/arch/alpha/package.use.mask
+++ b/profiles/arch/alpha/package.use.mask
@@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+# Alexandre Rostovtsev <tetromino@gentoo.org> (28 Jun 2016)
+# Missing keywords on app-text/gspell - bug #587368
+>=app-editors/gedit-3.20 spell
+
# Tobias Klausmann <klausman@gentoo.org> (14 Jun 2016)
# asciidoctor pulls in a lot of Ruby deps
>=net-misc/chrony-2.4_pre1 html
diff --git a/profiles/arch/arm/package.use.mask b/profiles/arch/arm/package.use.mask
index 035f00269207..1cb607725211 100644
--- a/profiles/arch/arm/package.use.mask
+++ b/profiles/arch/arm/package.use.mask
@@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+# Alexandre Rostovtsev <tetromino@gentoo.org> (28 Jun 2016)
+# Missing keywords on app-text/gspell - bug #587368
+>=app-editors/gedit-3.20 spell
+
# Göktürk Yüksek <gokturk@gentoo.org> (14 June 2016) on behalf of
# Nicholas Vinson <nvinso234@gmail.com> (proxy-maint)
# net-firewall/nftables[doc] requires dblatex which is not keyworded
diff --git a/profiles/arch/ia64/package.use.mask b/profiles/arch/ia64/package.use.mask
index 605c0d8fc6a2..184091325707 100644
--- a/profiles/arch/ia64/package.use.mask
+++ b/profiles/arch/ia64/package.use.mask
@@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+# Alexandre Rostovtsev <tetromino@gentoo.org> (28 Jun 2016)
+# Missing keywords on app-text/gspell - bug #587368
+>=app-editors/gedit-3.20 spell
+
# Justin Lecher <jlec@gentoo.org> (22 Feb 2016)
# Missing test deps keyword #575366
dev-cpp/eigen test
diff --git a/profiles/arch/powerpc/ppc32/package.use.mask b/profiles/arch/powerpc/ppc32/package.use.mask
index c7720a701bdc..d640cad5cd14 100644
--- a/profiles/arch/powerpc/ppc32/package.use.mask
+++ b/profiles/arch/powerpc/ppc32/package.use.mask
@@ -4,6 +4,10 @@
# This file requires >=portage-2.1.1
+# Alexandre Rostovtsev <tetromino@gentoo.org> (28 Jun 2016)
+# Missing keywords on app-text/gspell - bug #587368
+>=app-editors/gedit-3.20 spell
+
# Davide Pesavento <pesa@gentoo.org> (06 Jun 2016)
# Requires media-libs/phonon[qt5], masked below
app-office/texstudio qt5
diff --git a/profiles/arch/powerpc/ppc64/package.use.mask b/profiles/arch/powerpc/ppc64/package.use.mask
index 89a0f1ac239e..f67b3a7dcf6c 100644
--- a/profiles/arch/powerpc/ppc64/package.use.mask
+++ b/profiles/arch/powerpc/ppc64/package.use.mask
@@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+# Alexandre Rostovtsev <tetromino@gentoo.org> (28 Jun 2016)
+# Missing keywords on app-text/gspell - bug #587368
+>=app-editors/gedit-3.20 spell
+
# Jeroen Roovers <jer@gentoo.org> (19 May 2016)
# pulls in many dev-ruby/asciidoctor dependencies (bug #583390)
net-misc/chrony html
diff --git a/profiles/arch/sparc/package.use.mask b/profiles/arch/sparc/package.use.mask
index 154c8e50ecdc..895b73e0e9cb 100644
--- a/profiles/arch/sparc/package.use.mask
+++ b/profiles/arch/sparc/package.use.mask
@@ -2,6 +2,10 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
+# Alexandre Rostovtsev <tetromino@gentoo.org> (28 Jun 2016)
+# Missing keywords on app-text/gspell - bug #587368
+>=app-editors/gedit-3.20 spell
+
# Ian Delaney <idella4@gentoo.org> (06 Apr 2016)
# on behalf of Ilya Tumaykin <itumaykin+gentoo@gmail.com>
# dev-libs/uchardet lacks sparc keyword. See bug #569114.