summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/kanatest/kanatest-0.4.8.ebuild18
1 files changed, 13 insertions, 5 deletions
diff --git a/app-misc/kanatest/kanatest-0.4.8.ebuild b/app-misc/kanatest/kanatest-0.4.8.ebuild
index 2d5929f2f05d..d24f05ecee86 100644
--- a/app-misc/kanatest/kanatest-0.4.8.ebuild
+++ b/app-misc/kanatest/kanatest-0.4.8.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=5
+
inherit autotools epatch gnome2-utils
DESCRIPTION="Visual flashcard tool for memorizing the Japanese Hiragana and Katakana alphabet"
@@ -11,14 +12,13 @@ SRC_URI="http://www.clayo.org/${PN}/${P}.tar.gz"
LICENSE="GPL-2 GPL-2+"
SLOT="0"
KEYWORDS="amd64 ppc ppc64 x86"
-IUSE=""
RDEPEND=">=x11-libs/gtk+-2.12:2=
dev-libs/libxml2:="
DEPEND="${RDEPEND}
virtual/pkgconfig"
-DOCS="AUTHORS TRANSLATORS ChangeLog README"
+DOCS=( AUTHORS TRANSLATORS ChangeLog README )
src_prepare() {
epatch \
@@ -35,6 +35,14 @@ src_prepare() {
eautoreconf
}
-pkg_preinst() { gnome2_icon_savelist; }
-pkg_postinst() { gnome2_icon_cache_update; }
-pkg_postrm() { gnome2_icon_cache_update; }
+pkg_preinst() {
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}