summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-arch/pbzip2/pbzip2-1.1.13.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/app-arch/pbzip2/pbzip2-1.1.13.ebuild b/app-arch/pbzip2/pbzip2-1.1.13.ebuild
index f9ccda454629..6304e2335b93 100644
--- a/app-arch/pbzip2/pbzip2-1.1.13.ebuild
+++ b/app-arch/pbzip2/pbzip2-1.1.13.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI="7"
-inherit flag-o-matic epatch toolchain-funcs
+inherit flag-o-matic toolchain-funcs
DESCRIPTION="Parallel bzip2 (de)compressor using libbz2"
HOMEPAGE="http://compression.ca/pbzip2/ https://launchpad.net/pbzip2"
@@ -21,10 +21,17 @@ RDEPEND="
DEPEND="${RDEPEND}
static? ( ${LIB_DEPEND} )"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.1.10-makefile.patch
+)
+
src_prepare() {
+ default
# https://bugs.launchpad.net/pbzip2/+bug/1746369
sed -i 's:"PRIuMAX":" PRIuMAX ":g' *.cpp || die
- epatch "${FILESDIR}"/${PN}-1.1.10-makefile.patch
+}
+
+src_configure() {
tc-export CXX
use static && append-ldflags -static
}