summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/boto/boto-2.39.0.ebuild6
1 files changed, 6 insertions, 0 deletions
diff --git a/dev-python/boto/boto-2.39.0.ebuild b/dev-python/boto/boto-2.39.0.ebuild
index 09e8e9d3272a..532f9359b21a 100644
--- a/dev-python/boto/boto-2.39.0.ebuild
+++ b/dev-python/boto/boto-2.39.0.ebuild
@@ -17,6 +17,8 @@ SLOT="0"
KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
IUSE="doc test"
+REQUIRED_USE="doc? ( || ( $(python_gen_useflags 'python2*') ) )"
+
DEPEND="
dev-python/setuptools[${PYTHON_USEDEP}]
test? ( dev-python/nose[${PYTHON_USEDEP}] )
@@ -25,6 +27,10 @@ DEPEND="
# requires Amazon Web Services keys to pass some tests
RESTRICT="test"
+pkg_setup() {
+ use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( 'python2*' )
+}
+
python_test() {
"${PYTHON}" tests/test.py -v || die "Tests fail with ${EPYTHON}"
}