summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sci-libs/gloo/files/gloo-2023.01.17-ssl3.patch19
-rw-r--r--sci-libs/gloo/gloo-2023.01.17-r2.ebuild (renamed from sci-libs/gloo/gloo-2023.01.17-r1.ebuild)1
2 files changed, 20 insertions, 0 deletions
diff --git a/sci-libs/gloo/files/gloo-2023.01.17-ssl3.patch b/sci-libs/gloo/files/gloo-2023.01.17-ssl3.patch
new file mode 100644
index 000000000000..f01beafa4596
--- /dev/null
+++ b/sci-libs/gloo/files/gloo-2023.01.17-ssl3.patch
@@ -0,0 +1,19 @@
+--- a/gloo/CMakeLists.txt 2023-11-27 22:39:53.709670525 +0100
++++ b/gloo/CMakeLists.txt 2023-11-27 22:42:29.784250524 +0100
+@@ -77,7 +77,7 @@
+ if(${CMAKE_SYSTEM_NAME} STREQUAL "Linux")
+ set(GLOO_HAVE_TRANSPORT_TCP 1)
+ if(${USE_TCP_OPENSSL_LINK} OR ${USE_TCP_OPENSSL_LOAD})
+- find_package(OpenSSL 1.1 REQUIRED EXACT)
++ find_package(OpenSSL 1.1...<4 REQUIRED)
+ set(GLOO_HAVE_TRANSPORT_TCP_TLS 1)
+ else()
+ set(GLOO_HAVE_TRANSPORT_TCP_TLS 0)
+--- a/gloo/test/CMakeLists.txt 2023-11-27 22:42:55.969844380 +0100
++++ b/gloo/test/CMakeLists.txt 2023-11-27 22:43:14.873551147 +0100
+@@ -1,4 +1,4 @@
+-find_package(OpenSSL 1.1 REQUIRED EXACT)
++find_package(OpenSSL 1.1...<4 REQUIRED)
+
+ set(GLOO_TEST_SRCS
+ "${CMAKE_CURRENT_SOURCE_DIR}/allgather_test.cc"
diff --git a/sci-libs/gloo/gloo-2023.01.17-r1.ebuild b/sci-libs/gloo/gloo-2023.01.17-r2.ebuild
index a2c76198f848..8518665b3cd4 100644
--- a/sci-libs/gloo/gloo-2023.01.17-r1.ebuild
+++ b/sci-libs/gloo/gloo-2023.01.17-r2.ebuild
@@ -37,6 +37,7 @@ S="${WORKDIR}"/${PN}-${CommitId}
PATCHES=(
"${FILESDIR}"/${PN}-2022.05.18-gentoo.patch
"${FILESDIR}"/${P}-cuda.patch
+ "${FILESDIR}"/${P}-ssl3.patch
)
src_prepare() {