summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/ipython/Manifest2
-rw-r--r--dev-python/ipython/ipython-5.4.1-r2.ebuild125
-rw-r--r--dev-python/ipython/ipython-5.8.0-r1.ebuild129
3 files changed, 0 insertions, 256 deletions
diff --git a/dev-python/ipython/Manifest b/dev-python/ipython/Manifest
index 662b98abafd7..a64ff38a19cc 100644
--- a/dev-python/ipython/Manifest
+++ b/dev-python/ipython/Manifest
@@ -1,3 +1 @@
-DIST ipython-5.4.1.tar.gz 4973571 BLAKE2B bbda7b5a172ea1e80a9867f036ef68d1d0ec0a7340d77d8b4bbce63c5db7d3aade106ee5a6d59fb7e2b773c37d8263e51e1eaaa81d582849a70de60e93b7205a SHA512 b37dae27a558585ec4f42fa22e86380ac81990207ec680fc7b0e6f97ac81c99d915cfe77488bc0b91a61c34e0c00b323df08aa06b142ce0fc88ce30203102907
-DIST ipython-5.8.0.tar.gz 4977824 BLAKE2B cfa0592e8b71f82d996e6e961c3ac478617132f569799916a8794f1af733f3e40649fea763595b58dd8a10f31869d280338b81d15c3d059707a66ff7dab889f5 SHA512 946afb8f1623c8a7564ba2d782e05f5c961577dfb1e4a0f27e4a10e2932d5d041035c12aea7eb3e1d61af87867fab85a29919499822f93f638634bc343084b3e
DIST ipython-7.5.0.tar.gz 5118610 BLAKE2B 3f89babc292ea55724c2333076a673ef7fcd0a7a468e972a50c962194a71a0bc3cc9bdea4f96db4c21fe475b4d79dc87c124bcde53e1bc3ae7066a3c0c136e0d SHA512 564027879e53b3716ebe8cb1ed4b516835c15f326c865fd664aa7a4e5f26e1a78a329ff8e19d4acf6249e2acf7382501114cd2258c38bba89f0f382f7dcda09b
diff --git a/dev-python/ipython/ipython-5.4.1-r2.ebuild b/dev-python/ipython/ipython-5.4.1-r2.ebuild
deleted file mode 100644
index 4d4f816c1dd6..000000000000
--- a/dev-python/ipython/ipython-5.4.1-r2.ebuild
+++ /dev/null
@@ -1,125 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE='readline,sqlite,threads(+)'
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="Advanced interactive shell for Python"
-HOMEPAGE="http://ipython.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~ppc ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- >=dev-python/jedi-0.10.0[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pickleshare[${PYTHON_USEDEP}]
- >=dev-python/prompt_toolkit-1.0.4[${PYTHON_USEDEP}]
- <dev-python/prompt_toolkit-2[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/simplegeneric[${PYTHON_USEDEP}]
- >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
- matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
-"
-
-RDEPEND="${CDEPEND}
- nbconvert? ( dev-python/nbconvert[${PYTHON_USEDEP}] )"
-DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- <dev-python/sphinx-2[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]
- )"
-
-PDEPEND="
- notebook? (
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP}]
- )
- qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
- smp? ( dev-python/ipyparallel[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/2.1.0-substitute-files.patch )
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # Remove out of date insource files
- rm IPython/extensions/cythonmagic.py || die
- rm IPython/extensions/rmagic.py || die
-
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html_noapi
- HTML_DOCS=( docs/build/html/. )
- fi
-}
-
-python_test() {
- distutils_install_for_testing
- pushd "${TEST_DIR}" >/dev/null || die
- "${TEST_DIR}"/scripts/iptest || die
- popd >/dev/null || die
-}
-
-python_install() {
- distutils-r1_python_install
-
- # Create ipythonX.Y symlinks.
- # TODO:
- # 1. do we want them for pypy? No. pypy has no numpy
- # 2. handle it in the eclass instead (use _python_ln_rel).
- # With pypy not an option the dosym becomes unconditional
- dosym ../lib/python-exec/${EPYTHON}/ipython \
- /usr/bin/ipython${EPYTHON#python}
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-pkg_postinst() {
- optfeature "sympyprinting" dev-python/sympy
- optfeature "cythonmagic" dev-python/cython
- optfeature "%lprun magic command" dev-python/line_profiler
- optfeature "%mprun magic command" dev-python/memory_profiler
-
- if use nbconvert; then
- if ! has_version app-text/pandoc ; then
- einfo "Node.js will be used to convert notebooks to other formats"
- einfo "like HTML. Support for that is still experimental. If you"
- einfo "encounter any problems, please use app-text/pandoc instead."
- fi
- fi
-}
diff --git a/dev-python/ipython/ipython-5.8.0-r1.ebuild b/dev-python/ipython/ipython-5.8.0-r1.ebuild
deleted file mode 100644
index 5c61058a4c4e..000000000000
--- a/dev-python/ipython/ipython-5.8.0-r1.ebuild
+++ /dev/null
@@ -1,129 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{6,7} )
-PYTHON_REQ_USE='readline,sqlite,threads(+)'
-
-inherit distutils-r1 eutils virtualx
-
-DESCRIPTION="Advanced interactive shell for Python"
-HOMEPAGE="http://ipython.org/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc examples matplotlib notebook nbconvert qt5 +smp test"
-RESTRICT="!test? ( test )"
-
-CDEPEND="
- dev-python/decorator[${PYTHON_USEDEP}]
- >=dev-python/jedi-0.10.0[${PYTHON_USEDEP}]
- dev-python/pexpect[${PYTHON_USEDEP}]
- dev-python/pickleshare[${PYTHON_USEDEP}]
- >=dev-python/prompt_toolkit-1.0.4[${PYTHON_USEDEP}]
- <dev-python/prompt_toolkit-2[${PYTHON_USEDEP}]
- dev-python/pyparsing[${PYTHON_USEDEP}]
- dev-python/simplegeneric[${PYTHON_USEDEP}]
- >=dev-python/traitlets-4.2.1[${PYTHON_USEDEP}]
- matplotlib? ( dev-python/matplotlib[${PYTHON_USEDEP}] )
-"
-
-RDEPEND="${CDEPEND}
- nbconvert? ( dev-python/nbconvert[${PYTHON_USEDEP}] )"
-DEPEND="${CDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- dev-python/nbformat[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/testpath[${PYTHON_USEDEP}]
- )
- doc? (
- dev-python/ipykernel[${PYTHON_USEDEP}]
- <dev-python/sphinx-2[${PYTHON_USEDEP}]
- dev-python/sphinxcontrib-websupport[${PYTHON_USEDEP}]
- )"
-
-PDEPEND="
- notebook? (
- dev-python/notebook[${PYTHON_USEDEP}]
- dev-python/ipywidgets[${PYTHON_USEDEP}]
- )
- qt5? ( dev-python/qtconsole[${PYTHON_USEDEP}] )
- smp? ( dev-python/ipyparallel[${PYTHON_USEDEP}] )"
-
-PATCHES=( "${FILESDIR}"/2.1.0-substitute-files.patch )
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # Remove out of date insource files
- rm IPython/extensions/cythonmagic.py || die
- rm IPython/extensions/rmagic.py || die
-
- # Prevent un-needed download during build
- if use doc; then
- sed -e "/^ 'sphinx.ext.intersphinx',/d" -i docs/source/conf.py || die
- fi
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- emake -C docs html_noapi
- HTML_DOCS=( docs/build/html/. )
- fi
-}
-
-src_test() {
- virtx distutils-r1_src_test
-}
-
-python_test() {
- distutils_install_for_testing
- pushd "${TEST_DIR}" >/dev/null || die
- "${TEST_DIR}"/scripts/iptest || die
- popd >/dev/null || die
-}
-
-python_install() {
- distutils-r1_python_install
-
- # Create ipythonX.Y symlinks.
- # TODO:
- # 1. do we want them for pypy? No. pypy has no numpy
- # 2. handle it in the eclass instead (use _python_ln_rel).
- # With pypy not an option the dosym becomes unconditional
- dosym ../lib/python-exec/${EPYTHON}/ipython \
- /usr/bin/ipython${EPYTHON#python}
-}
-
-python_install_all() {
- distutils-r1_python_install_all
-
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
-}
-
-pkg_postinst() {
- optfeature "sympyprinting" dev-python/sympy
- optfeature "cythonmagic" dev-python/cython
- optfeature "%lprun magic command" dev-python/line_profiler
- optfeature "%mprun magic command" dev-python/memory_profiler
-
- if use nbconvert; then
- if ! has_version app-text/pandoc ; then
- einfo "Node.js will be used to convert notebooks to other formats"
- einfo "like HTML. Support for that is still experimental. If you"
- einfo "encounter any problems, please use app-text/pandoc instead."
- fi
- fi
-}