summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/cachelib/Manifest1
-rw-r--r--dev-python/cachelib/cachelib-0.10.1.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/cachelib/Manifest b/dev-python/cachelib/Manifest
index 8407e64db8b8..fc76c95699e4 100644
--- a/dev-python/cachelib/Manifest
+++ b/dev-python/cachelib/Manifest
@@ -1 +1,2 @@
+DIST cachelib-0.10.1.gh.tar.gz 29232 BLAKE2B e5cdc9282741aac039a90943ba912274f227a93168656e757994781672ae73cba820d1b737c582716fa0711cf74572d2f81b0a495af6b006ff9138e0180c5758 SHA512 4366b6b0e1291cfd84de60927c61e127af7750b4f7437ba34dc6f5542997b01e3525ef628c7dc4325087fa60cb2e9633b1fd32fdc7d93ebe697333ca0e30355f
DIST cachelib-0.9.0.gh.tar.gz 26407 BLAKE2B 8b1b6c725f5869fda4752db64ab4ee9ee9c748f0ed7e73cb5a9967d18d461cc29779a1e3dc18fcf4b9152f9586ed342fb97e75b4a9b7cb6f5efdeee02f8cf13e SHA512 53b214ba95b0e368e48ddc1e9f904497055e4c37deb0d1946419c3b294eb0e999ea690f2b79bd4801ad80201fb823927bc2024cc493006e20f623955850bba71
diff --git a/dev-python/cachelib/cachelib-0.10.1.ebuild b/dev-python/cachelib/cachelib-0.10.1.ebuild
new file mode 100644
index 000000000000..74784a2e4520
--- /dev/null
+++ b/dev-python/cachelib/cachelib-0.10.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Collection of cache libraries in the same API interface. Extracted from werkzeug"
+HOMEPAGE="
+ https://pypi.org/project/cachelib/
+ https://github.com/pallets-eco/cachelib/
+"
+SRC_URI="
+ https://github.com/pallets-eco/cachelib/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-db/redis
+ dev-python/pylibmc[${PYTHON_USEDEP}]
+ dev-python/pytest-xprocess[${PYTHON_USEDEP}]
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ net-misc/memcached
+ www-servers/uwsgi[python,${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # bug #818523
+ tests/test_redis_cache.py
+ # requires some test server running
+ # (these tests require dev-python/boto3)
+ tests/test_dynamodb_cache.py
+)