summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/raft/Manifest1
-rw-r--r--dev-libs/raft/raft-0.18.0.ebuild55
2 files changed, 56 insertions, 0 deletions
diff --git a/dev-libs/raft/Manifest b/dev-libs/raft/Manifest
index 41a25caa352f..fc9b6fd7c5b3 100644
--- a/dev-libs/raft/Manifest
+++ b/dev-libs/raft/Manifest
@@ -1 +1,2 @@
DIST raft-0.17.1.tar.gz 354331 BLAKE2B d1be3eb4139422dab8126879d2ba0782e8635a60ce9752f4389f79dd2238021d9679d3b5f799c9627921c954a4395cdff139ff41f8145ebc43190f2c4aa3e5a7 SHA512 20e2b4a144a597b77bcb31e8b22355725142b14fb50e20b33509e7b0dd10aa20d08501b66e836c659e9aa492184db71ea9e53a45fe4b908b1464eb94431154db
+DIST raft-0.18.0.tar.gz 365558 BLAKE2B 57fc8c144a45eb101f53c8dd3a1eb896c733b7c5c369300852bea1474b8178b46c943c29e81107758bfa527d8fc1a9c80c4ca1bfc599dfc5ace090a18c693f11 SHA512 c6ab125a4841c5241310ea9785bb6ae3860c0a2ff39487499c2caa0b387729f7f7e54fa0de3aad3a99bdf5ec7d4a12c68a69244c6d8b8dcdf846c1cdfeb11b3b
diff --git a/dev-libs/raft/raft-0.18.0.ebuild b/dev-libs/raft/raft-0.18.0.ebuild
new file mode 100644
index 000000000000..5850e6b47490
--- /dev/null
+++ b/dev-libs/raft/raft-0.18.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools
+
+DESCRIPTION="C implementation of the Raft consensus protocol"
+HOMEPAGE="https://github.com/canonical/raft"
+SRC_URI="https://github.com/canonical/raft/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3-with-linking-exception"
+SLOT="0/3"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="lz4 test zfs"
+RESTRICT="!test? ( test )"
+
+DEPEND="dev-libs/libuv:=
+ lz4? ( app-arch/lz4:= )"
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/raft-0.10.0-toggle-zfs.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-uv
+
+ --disable-backtrace
+ --disable-benchmark
+ --disable-debug
+ --disable-example
+ --disable-sanitize
+ --disable-static
+
+ $(use_enable test fixture)
+
+ $(use_with lz4)
+ $(use_with zfs)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}