summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-apps/wayvnc/Manifest1
-rw-r--r--gui-apps/wayvnc/metadata.xml24
-rw-r--r--gui-apps/wayvnc/wayvnc-0.4.0.ebuild44
-rw-r--r--gui-apps/wayvnc/wayvnc-9999.ebuild44
4 files changed, 113 insertions, 0 deletions
diff --git a/gui-apps/wayvnc/Manifest b/gui-apps/wayvnc/Manifest
new file mode 100644
index 000000000000..1bc4a3ef8614
--- /dev/null
+++ b/gui-apps/wayvnc/Manifest
@@ -0,0 +1 @@
+DIST wayvnc-0.4.0.tar.gz 52157 BLAKE2B 7c8456d5136ef361ca7dd72ffa7501514eeb7a61ae1777a02391fb7fceea6b020d68951300ab76254f2afd5e2610fe66ce0f461d18dc38522706691438f4620e SHA512 b8f1af24213077dc6126ae1f613b9cdeed8f365f9d1989a5b053563f0eb4bc49921e746e0f1026fe0e02bfeea23b912798678a5a337a052d977aa04496a75570
diff --git a/gui-apps/wayvnc/metadata.xml b/gui-apps/wayvnc/metadata.xml
new file mode 100644
index 000000000000..32c02efdbf9e
--- /dev/null
+++ b/gui-apps/wayvnc/metadata.xml
@@ -0,0 +1,24 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <longdescription>
+ VNC server for wlroots based Wayland compositors.
+ It attaches to a running Wayland session, creates
+ virtual input devices and exposes a single display
+ via the RFB protocol. The Wayland session may be a
+ headless one, so it is also possible to run wayvnc
+ without a physical display attached.
+ </longdescription>
+ <maintainer type="person">
+ <email>gentoo@aisha.cc</email>
+ <name>Aisha Tammy</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <use>
+ <flag name="gbm">enable GPU-side screencopy (experimental)</flag>
+ <flag name="tracing">Trace kernel and memory calls</flag>
+ </use>
+</pkgmetadata>
diff --git a/gui-apps/wayvnc/wayvnc-0.4.0.ebuild b/gui-apps/wayvnc/wayvnc-0.4.0.ebuild
new file mode 100644
index 000000000000..369ff2e67cac
--- /dev/null
+++ b/gui-apps/wayvnc/wayvnc-0.4.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="gbm tracing"
+
+RDEPEND="
+ dev-libs/aml
+ dev-libs/wayland
+ gui-libs/neatvnc[tracing?]
+ media-libs/mesa:=[egl,gles2,gbm?]
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ tracing? ( dev-util/systemtap )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gbm screencopy-dmabuf)
+ $(meson_use tracing systemtap)
+ )
+ meson_src_configure
+}
diff --git a/gui-apps/wayvnc/wayvnc-9999.ebuild b/gui-apps/wayvnc/wayvnc-9999.ebuild
new file mode 100644
index 000000000000..369ff2e67cac
--- /dev/null
+++ b/gui-apps/wayvnc/wayvnc-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson
+
+DESCRIPTION="VNC server for wlroots based Wayland compositors"
+HOMEPAGE="https://github.com/any1/wayvnc"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/any1/wayvnc.git"
+else
+ SRC_URI="https://github.com/any1/wayvnc/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="ISC"
+SLOT="0"
+IUSE="gbm tracing"
+
+RDEPEND="
+ dev-libs/aml
+ dev-libs/wayland
+ gui-libs/neatvnc[tracing?]
+ media-libs/mesa:=[egl,gles2,gbm?]
+ x11-libs/libxkbcommon
+ x11-libs/pixman
+ tracing? ( dev-util/systemtap )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ dev-libs/wayland-protocols
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_feature gbm screencopy-dmabuf)
+ $(meson_use tracing systemtap)
+ )
+ meson_src_configure
+}