summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-java/openjdk-bin/openjdk-bin-11.0.13_p8-r1.ebuild2
-rw-r--r--dev-java/openjdk-bin/openjdk-bin-11.0.14_p9.ebuild2
-rw-r--r--dev-java/openjdk-bin/openjdk-bin-17.0.1_p12-r1.ebuild4
-rw-r--r--dev-java/openjdk-bin/openjdk-bin-8.312_p07-r1.ebuild4
4 files changed, 6 insertions, 6 deletions
diff --git a/dev-java/openjdk-bin/openjdk-bin-11.0.13_p8-r1.ebuild b/dev-java/openjdk-bin/openjdk-bin-11.0.13_p8-r1.ebuild
index dabdb239f42e..bc75e084b8ea 100644
--- a/dev-java/openjdk-bin/openjdk-bin-11.0.13_p8-r1.ebuild
+++ b/dev-java/openjdk-bin/openjdk-bin-11.0.13_p8-r1.ebuild
@@ -74,7 +74,7 @@ src_unpack() {
src_install() {
local dest="/opt/${P}"
- local ddest="${ED%/}/${dest#/}"
+ local ddest="${ED}/${dest#/}"
# on macOS if they would exist they would be called .dylib, but most
# importantly, there are no different providers, so everything
diff --git a/dev-java/openjdk-bin/openjdk-bin-11.0.14_p9.ebuild b/dev-java/openjdk-bin/openjdk-bin-11.0.14_p9.ebuild
index 13a7af71723e..019ca529d3b6 100644
--- a/dev-java/openjdk-bin/openjdk-bin-11.0.14_p9.ebuild
+++ b/dev-java/openjdk-bin/openjdk-bin-11.0.14_p9.ebuild
@@ -72,7 +72,7 @@ src_unpack() {
src_install() {
local dest="/opt/${PN}-${SLOT}"
- local ddest="${ED%/}/${dest#/}"
+ local ddest="${ED}/${dest#/}"
# on macOS if they would exist they would be called .dylib, but most
# importantly, there are no different providers, so everything
diff --git a/dev-java/openjdk-bin/openjdk-bin-17.0.1_p12-r1.ebuild b/dev-java/openjdk-bin/openjdk-bin-17.0.1_p12-r1.ebuild
index bdeb4a67273d..bcac729452c5 100644
--- a/dev-java/openjdk-bin/openjdk-bin-17.0.1_p12-r1.ebuild
+++ b/dev-java/openjdk-bin/openjdk-bin-17.0.1_p12-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -85,7 +85,7 @@ src_unpack() {
src_install() {
local dest="/opt/${P}"
- local ddest="${ED%/}/${dest#/}"
+ local ddest="${ED}/${dest#/}"
# on macOS if they would exist they would be called .dylib, but most
# importantly, there are no different providers, so everything
diff --git a/dev-java/openjdk-bin/openjdk-bin-8.312_p07-r1.ebuild b/dev-java/openjdk-bin/openjdk-bin-8.312_p07-r1.ebuild
index 465e0a290547..3144abff510b 100644
--- a/dev-java/openjdk-bin/openjdk-bin-8.312_p07-r1.ebuild
+++ b/dev-java/openjdk-bin/openjdk-bin-8.312_p07-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -77,7 +77,7 @@ src_unpack() {
src_install() {
local dest="/opt/${P}"
- local ddest="${ED%/}/${dest#/}"
+ local ddest="${ED}/${dest#/}"
rm ASSEMBLY_EXCEPTION LICENSE THIRD_PARTY_README || die