summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-emulation/podman/podman-3.1.2-r1.ebuild (renamed from app-emulation/podman/podman-3.1.2.ebuild)4
-rw-r--r--app-emulation/podman/podman-3.2.1-r1.ebuild (renamed from app-emulation/podman/podman-3.2.1.ebuild)4
2 files changed, 6 insertions, 2 deletions
diff --git a/app-emulation/podman/podman-3.1.2.ebuild b/app-emulation/podman/podman-3.1.2-r1.ebuild
index 1ab7287d3c70..ce8fb2e74712 100644
--- a/app-emulation/podman/podman-3.1.2.ebuild
+++ b/app-emulation/podman/podman-3.1.2-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
EGIT_COMMIT="51b8ddbc22cf5b10dd76dd9243924aa66ad7db39"
-inherit bash-completion-r1 flag-o-matic go-module
+inherit bash-completion-r1 flag-o-matic go-module tmpfiles
DESCRIPTION="Library and podman tool for running OCI-based containers in Pods"
HOMEPAGE="https://github.com/containers/podman/"
@@ -140,6 +140,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ tmpfiles_process podman.conf
+
local want_newline=false
if [[ ! ( -e ${EROOT%/*}/etc/containers/policy.json && -e ${EROOT%/*}/etc/containers/registries.conf ) ]]; then
elog "You need to create the following config files:"
diff --git a/app-emulation/podman/podman-3.2.1.ebuild b/app-emulation/podman/podman-3.2.1-r1.ebuild
index 26de438a63d5..090d5367af64 100644
--- a/app-emulation/podman/podman-3.2.1.ebuild
+++ b/app-emulation/podman/podman-3.2.1-r1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
EGIT_COMMIT="152952fe6b18581615c3efd1fafef2d8142738e8"
-inherit bash-completion-r1 flag-o-matic go-module
+inherit bash-completion-r1 flag-o-matic go-module tmpfiles
DESCRIPTION="Library and podman tool for running OCI-based containers in Pods"
HOMEPAGE="https://github.com/containers/podman/"
@@ -140,6 +140,8 @@ pkg_preinst() {
}
pkg_postinst() {
+ tmpfiles_process podman.conf
+
local want_newline=false
if [[ ! ( -e ${EROOT%/*}/etc/containers/policy.json && -e ${EROOT%/*}/etc/containers/registries.conf ) ]]; then
elog "You need to create the following config files:"