summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-vcs/tortoisehg/Manifest1
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-6.5.1.ebuild81
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild2
3 files changed, 83 insertions, 1 deletions
diff --git a/dev-vcs/tortoisehg/Manifest b/dev-vcs/tortoisehg/Manifest
index 708e098285dc..5a5d0b72e572 100644
--- a/dev-vcs/tortoisehg/Manifest
+++ b/dev-vcs/tortoisehg/Manifest
@@ -2,3 +2,4 @@ DIST tortoisehg-6.2.3.tar.gz 8878641 BLAKE2B ede267f48c7b58db1fcdf16a11fb343e4fc
DIST tortoisehg-6.3.2.tar.gz 8885325 BLAKE2B bb9a7043f7d2e44b32e20b6dd88372927977a6fd94b662a8a56d26776c72268e0953de3edc93b2f7b9efc580286632f500f5181a5ef7bf3edd3fb5ba5ec64761 SHA512 b711f9d347b2f00978b42b258713d365188c4de100668a09fea4b6f80bb8083a7980a462b8fb4705d31f9da310dbdeb2d9891e93f6e3f6f2833e4c7ccfa4d800
DIST tortoisehg-6.4.2.tar.gz 8854453 BLAKE2B 04c57de8ea745cdcd33fe8a65b95f76937b59f01486eec6f305eed52dceaed898d55b95769de8a4f41606a3dda6d81e44d3eb1690ee6dde7ab21526b2a46032d SHA512 efe23a991130423aa374e7dd5fe051fabcc6d48c3596a355c7d21dfa35de062411cf2edc3efe4800146c6b3ab4dbd064da54a4f27988297cfd6dc1f69ab14e22
DIST tortoisehg-6.4.5.tar.gz 8854488 BLAKE2B a66478e04d2effe4f79b57789352f8c4a4dcca577c70292a6297cab6abb4738c2bb53979d636d3b1ca511ce3313bde598bd4bafa3ac78fa91262ba9c10e1d8c8 SHA512 cbde470405f1247b93a658c49ff6c0d188e283915825147a05f1957db382596ee35da7b1becd01bf21eb9f5672231efa3adf092bcca05d7d630c2fd1d8aa7338
+DIST tortoisehg-6.5.1.tar.gz 8854923 BLAKE2B 7536f5d7c2b0cda5bb812b2135dcb54ce9bf02a523648e4569bbca5772d3568a63cb09549b6e10c46d212e3c98791f3014b62386d68b488f78f57a235e0be36c SHA512 0e568937f25afa681e8c5f8b8ecc40ede046999318ff80bdd27516b523169c778c695a2a800876eac40480d6e009c83c6493dec3110673f5b79f284be1d4948b
diff --git a/dev-vcs/tortoisehg/tortoisehg-6.5.1.ebuild b/dev-vcs/tortoisehg/tortoisehg-6.5.1.ebuild
new file mode 100644
index 000000000000..372918b6780f
--- /dev/null
+++ b/dev-vcs/tortoisehg/tortoisehg-6.5.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit desktop distutils-r1 optfeature xdg-utils
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ SRC_URI="https://foss.heptapod.net/mercurial/${PN}/thg/-/archive/${PV}/thg-${PV}.tar.gz -> ${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-6.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '>=dev-vcs/mercurial-6.3.2[${PYTHON_USEDEP}]' python3_11 )
+ <dev-vcs/mercurial-6.6[${PYTHON_USEDEP}]"
+ S="${WORKDIR}/thg-${PV}"
+else
+ inherit mercurial
+ EHG_REPO_URI="https://foss.heptapod.net/mercurial/${PN}/thg"
+ EHG_REVISION="stable"
+ HG_DEPEND=">=dev-vcs/mercurial-6.2[${PYTHON_USEDEP}]"
+fi
+
+DESCRIPTION="Set of graphical tools for Mercurial"
+HOMEPAGE="https://tortoisehg.bitbucket.io/"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ ${HG_DEPEND}
+ dev-python/iniparse[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/PyQt5[network,svg,${PYTHON_USEDEP}]
+ >=dev-python/qscintilla-python-2.11.6[qt5(+),${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx doc/source
+
+python_prepare_all() {
+ # Remove file that collides with >=mercurial-4.0 (bug #599266).
+ rm "${S}"/hgext3rd/__init__.py || die "can't remove /hgext3rd/__init__.py"
+
+ sed -i -e 's:share/doc/tortoisehg:share/doc/'"${PF}"':' setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ ${EPYTHON} tests/run-tests.py -m 'not largefiles' --disable-pytest-warnings --doctest-modules tests || die "Tests failed with ${EPYTHON}"
+ ${EPYTHON} tests/run-tests.py -m largefiles --disable-pytest-warnings tests || die "Tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ dodoc doc/ReadMe*.txt doc/TODO contrib/mergetools.rc
+ newicon -s scalable icons/scalable/apps/thg.svg thg_logo.svg
+ domenu contrib/thg.desktop
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ elog "When startup of ${PN} fails with an API version mismatch error"
+ elog "between dev-python/sip and dev-python/PyQt5 please rebuild"
+ elog "dev-python/qscintilla-python."
+
+ optfeature "the core git extension support" dev-python/pygit2
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index 4ac9450fad29..372918b6780f 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -13,7 +13,7 @@ if [[ ${PV} != *9999* ]]; then
SRC_URI="https://foss.heptapod.net/mercurial/${PN}/thg/-/archive/${PV}/thg-${PV}.tar.gz -> ${P}.tar.gz"
HG_DEPEND=">=dev-vcs/mercurial-6.2[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-vcs/mercurial-6.3.2[${PYTHON_USEDEP}]' python3_11 )
- <dev-vcs/mercurial-6.5[${PYTHON_USEDEP}]"
+ <dev-vcs/mercurial-6.6[${PYTHON_USEDEP}]"
S="${WORKDIR}/thg-${PV}"
else
inherit mercurial