summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-text/libgepub/Manifest1
-rw-r--r--app-text/libgepub/libgepub-0.4.ebuild35
-rw-r--r--app-text/libgepub/metadata.xml8
3 files changed, 44 insertions, 0 deletions
diff --git a/app-text/libgepub/Manifest b/app-text/libgepub/Manifest
new file mode 100644
index 000000000000..af1943e2e2b8
--- /dev/null
+++ b/app-text/libgepub/Manifest
@@ -0,0 +1 @@
+DIST libgepub-0.4.tar.xz 246016 SHA256 5666a1c4d186d205bd2d91b71d4c1cd5426025569114a765dd913a564f149ff4 SHA512 dd3e9837ba2c5896319918bda19eec8ea790d54f7893ddca46774f96f8e09ac1962ae6cbfc0bcd23c15059c63683ef4a6673e05f8416b024591677fddfa3ca15 WHIRLPOOL 024fe741655adc6fafb66f797fe77e39845764d7fb328f8c553d3cd5917d00e996b030f83342af5789e00bd54569eb25cc0728fd690bf03ae62ab6a9aef96652
diff --git a/app-text/libgepub/libgepub-0.4.ebuild b/app-text/libgepub/libgepub-0.4.ebuild
new file mode 100644
index 000000000000..d2854c747225
--- /dev/null
+++ b/app-text/libgepub/libgepub-0.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit gnome2
+
+DESCRIPTION="GObject based library for handling and rendering epub documents"
+HOMEPAGE="https://git.gnome.org/browse/libgepub"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+introspection"
+
+RDEPEND="
+ app-arch/libarchive
+ dev-libs/glib:2
+ dev-libs/libxml2
+ net-libs/libsoup:2.4
+ net-libs/webkit-gtk:4
+ x11-libs/gtk+:3
+ introspection? ( >=dev-libs/gobject-introspection-1.30:= )
+"
+DEPEND="${RDEPEND}
+ gnome-base/gnome-common
+ virtual/pkgconfig
+"
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable introspection)
+}
diff --git a/app-text/libgepub/metadata.xml b/app-text/libgepub/metadata.xml
new file mode 100644
index 000000000000..4cbddcaa19ad
--- /dev/null
+++ b/app-text/libgepub/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>gnome@gentoo.org</email>
+ <name>Gentoo GNOME Desktop</name>
+ </maintainer>
+</pkgmetadata>