summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--kde-misc/zanshin/files/zanshin-0.5.0-cmake.patch25
-rw-r--r--kde-misc/zanshin/zanshin-0.5.0.ebuild4
2 files changed, 28 insertions, 1 deletions
diff --git a/kde-misc/zanshin/files/zanshin-0.5.0-cmake.patch b/kde-misc/zanshin/files/zanshin-0.5.0-cmake.patch
new file mode 100644
index 000000000000..6d6facbaeaa2
--- /dev/null
+++ b/kde-misc/zanshin/files/zanshin-0.5.0-cmake.patch
@@ -0,0 +1,25 @@
+From 87e98e6b0aa704558009574eed8d8bdf2bfa0fbb Mon Sep 17 00:00:00 2001
+From: Andreas Sturmlechner <asturm@gentoo.org>
+Date: Sat, 22 Jun 2019 12:47:28 +0200
+Subject: [PATCH] Add missing KF5 dependency (fix broken cmake against >=19.04)
+
+Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
+---
+ CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index a6191f54..960fc6c7 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -67,6 +67,7 @@ include_directories (
+
+ find_package(KF5 REQUIRED COMPONENTS
+ AkonadiCalendar
++ AkonadiContact
+ AkonadiNotes
+ AkonadiSearch
+ IdentityManagement
+--
+2.22.0
+
diff --git a/kde-misc/zanshin/zanshin-0.5.0.ebuild b/kde-misc/zanshin/zanshin-0.5.0.ebuild
index 3a8f084bb7bf..96b3141c24ec 100644
--- a/kde-misc/zanshin/zanshin-0.5.0.ebuild
+++ b/kde-misc/zanshin/zanshin-0.5.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -60,3 +60,5 @@ RDEPEND="${COMMON_DEPEND}
!kde-misc/zanshin:4
$(add_kdeapps_dep kdepim-runtime)
"
+
+PATCHES=( "${FILESDIR}/${P}-cmake.patch" )