summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-libs/log4sh/log4sh-1.4.2.ebuild15
1 files changed, 7 insertions, 8 deletions
diff --git a/dev-libs/log4sh/log4sh-1.4.2.ebuild b/dev-libs/log4sh/log4sh-1.4.2.ebuild
index bb98dc57cf64..09caddd99216 100644
--- a/dev-libs/log4sh/log4sh-1.4.2.ebuild
+++ b/dev-libs/log4sh/log4sh-1.4.2.ebuild
@@ -1,9 +1,7 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-
-inherit eutils
+EAPI=7
DESCRIPTION="A flexible logging framework for shell scripts"
HOMEPAGE="https://sourceforge.net/projects/log4sh"
@@ -22,8 +20,7 @@ src_compile() {
src_test() {
# testsuite needs USER variable
- export USER="$(whoami)"
- make test || die "make test failed"
+ USER="$(whoami)" emake test
}
src_install() {
@@ -31,7 +28,9 @@ src_install() {
doins build/log4sh
dodoc doc/*.txt
- dohtml doc/*.{html,css}
+
+ docinto html
+ dodoc doc/*.{html,css}
if use examples; then
docinto examples
@@ -41,7 +40,7 @@ src_install() {
}
pkg_postinst() {
- elog "To use log4sh, have your script source /usr/lib/log4sh/log4sh"
+ elog "To use log4sh, have your script source ${EPREFIX}/usr/lib/log4sh/log4sh"
elog "If you want to use remote logging, you should install package,"
elog "that provides netcat binary (for example - net-analyzer/netcat)"
}