summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-misc/bijiben/Manifest1
-rw-r--r--app-misc/bijiben/bijiben-3.32.2.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-misc/bijiben/Manifest b/app-misc/bijiben/Manifest
index 31bd023838fb..5b464843652d 100644
--- a/app-misc/bijiben/Manifest
+++ b/app-misc/bijiben/Manifest
@@ -1 +1,2 @@
DIST bijiben-3.26.2.tar.xz 865148 BLAKE2B 77bb78745295d414153e18491fd16faad29defabaff4ad979db7cc6e6fe075e042dd8b04d321282fbfbf163541818019bc2cbda0f8562010dfc32f275f3f54e8 SHA512 1db8c5e605b5c6a0fcd8743365a53b6ab2d986a18d501a3f02e892bcfc8ba91e9ca933b6f2a4318f71724b40f190d0ebc18eabfe1332de6765b9bca09d36718e
+DIST bijiben-3.32.2.tar.xz 659988 BLAKE2B a155b3ad4d340b6efe039ae8458be6665f5ea37935b2040d8aa59f4b019a7ce2a9bb42c309fbc212b8f87cd2e3db533305b64d6987b3b527435ab9906165a7ff SHA512 71573ced01a5e984998fc5ce97ebbd4fcf04a91165465697ff29ea67076a31654b8f66a93c3ed79b30a8af2e38fad3ac4bfc3047106411078c6cbb67c20d5c5d
diff --git a/app-misc/bijiben/bijiben-3.32.2.ebuild b/app-misc/bijiben/bijiben-3.32.2.ebuild
new file mode 100644
index 000000000000..9d14aaf463c2
--- /dev/null
+++ b/app-misc/bijiben/bijiben-3.32.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit gnome.org gnome2-utils meson xdg
+
+DESCRIPTION="Note editor designed to remain simple to use"
+HOMEPAGE="https://wiki.gnome.org/Apps/Notes"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ app-misc/tracker:0/2.0
+ >=dev-libs/glib-2.53.4:2
+ net-libs/gnome-online-accounts:=
+ >=x11-libs/gtk+-3.19.3:3
+ >=gnome-extra/evolution-data-server-3.13.90:=
+ dev-libs/libxml2:2
+ sys-apps/util-linux
+ >=net-libs/webkit-gtk-2.10:4
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-libs/appstream-glib
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ -Dzeitgeist=false
+ -Dupdate_mimedb=false
+ -Dprivate_store=false # private store is mainly meant for flatpak builds
+ )
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}