summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--sys-boot/raspberrypi-firmware/Manifest2
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190215.ebuild60
-rw-r--r--sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190709.ebuild60
3 files changed, 0 insertions, 122 deletions
diff --git a/sys-boot/raspberrypi-firmware/Manifest b/sys-boot/raspberrypi-firmware/Manifest
index 2d1c89bcef4e..1520157a4089 100644
--- a/sys-boot/raspberrypi-firmware/Manifest
+++ b/sys-boot/raspberrypi-firmware/Manifest
@@ -1,4 +1,2 @@
-DIST raspberrypi-firmware-1.20190215.tar.gz 123074917 BLAKE2B cefedb5c979db7dfd47938aad37a567d91d3ad78247c7a63f789362768ab7a39a1967ac116b4b0475e3b210ab11f6474706df042af85a622e8e7905c85ec7498 SHA512 082f26caf427222d838881e5f1e9fa0136765b3eaf74a84877fc33616fd07e49085db0889226c40c655039a9d41a10566510c7d752cfc48a67b4683616a51193
-DIST raspberrypi-firmware-1.20190709.tar.gz 158835870 BLAKE2B 4e63b3308adcd75f69f66966f1c927449aa8dc65211e6ca5a27dd2a0ed6ed32cc85ad42221308f4fb3a852d9f278400cfe4f723f306abe102341568408027174 SHA512 6a0610c97db47441ede8e4f8436958899f678bf065a0fbde06de7945a1ac4d5f754a0e10d928d77759ba1cbf82654d85d9cb9c91b970c3fe9590560267033522
DIST raspberrypi-firmware-1.20190925.tar.gz 185571086 BLAKE2B c3a9b2760fa853fbd1dd09bc4048c9e78594f88da5af608c3a761554d4046a4c869db8981c64140a24e82e0a61b8dc776bb8d895df60c6424e44780f78b18cb0 SHA512 4b7b29cc6c2a33d7a37987c492034d9afbb2220364c50cf265e0adf8e5f393c2275dcffaa77c89b3f43b2e98d199741b67590cb60ff8beae8ef677852f63b4a0
DIST raspberrypi-firmware-1.20201022.tar.gz 189827375 BLAKE2B 94c38f60d688c8e3ebab830912daccbb6c04bdd3d88f6ca0d07d85be0a6b12c53f0266b4c258ed4694f30bad5db30fb6d30feabfd0b7668735a9a806b820d325 SHA512 876758179df27109984b6c3f4849fdcdc6bdcc2769495fcc83c97fc3ff4d07b9f3cd58086be877503f72c9e5417d2be6d6c33bce4cbb3b862055117c9cc26db8
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190215.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190215.ebuild
deleted file mode 100644
index 4b06dfa49939..000000000000
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190215.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit mount-boot readme.gentoo-r1
-
-DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
-HOMEPAGE="https://github.com/raspberrypi/firmware"
-LICENSE="GPL-2 raspberrypi-videocore-bin"
-SLOT="0"
-
-if [[ "${PV}" == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
- EGIT_CLONE_TYPE="shallow"
-else
- SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="-* ~arm"
- S="${WORKDIR}/firmware-${PV}"
-fi
-
-RESTRICT="binchecks strip"
-
-pkg_preinst() {
- if [ -z "${REPLACING_VERSIONS}" ] ; then
- local msg=""
- if [ -e "${D}"/boot/cmdline.txt -a -e /boot/cmdline.txt ] ; then
- msg+="/boot/cmdline.txt "
- fi
- if [ -e "${D}"/boot/config.txt -a -e /boot/config.txt ] ; then
- msg+="/boot/config.txt "
- fi
- if [ -n "${msg}" ] ; then
- msg="This package installs following files: ${msg}."
- msg="${msg} Please remove(backup) your copies durning install"
- msg="${msg} and merge settings afterwards."
- msg="${msg} Further updates will be CONFIG_PROTECTed."
- die "${msg}"
- fi
- fi
-}
-
-src_install() {
- insinto /boot
- cd boot || die
- doins bootcode.bin fixup*.dat start*elf
- doins *.dtb
- doins -r overlays
- newins "${FILESDIR}"/${PN}-0_p20130711-config.txt config.txt
- newins "${FILESDIR}"/${PN}-0_p20130711-cmdline.txt cmdline.txt
- newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
-
-DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"
diff --git a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190709.ebuild b/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190709.ebuild
deleted file mode 100644
index 4b06dfa49939..000000000000
--- a/sys-boot/raspberrypi-firmware/raspberrypi-firmware-1.20190709.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit mount-boot readme.gentoo-r1
-
-DESCRIPTION="Raspberry Pi (all versions) bootloader and GPU firmware"
-HOMEPAGE="https://github.com/raspberrypi/firmware"
-LICENSE="GPL-2 raspberrypi-videocore-bin"
-SLOT="0"
-
-if [[ "${PV}" == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
- EGIT_CLONE_TYPE="shallow"
-else
- SRC_URI="https://github.com/raspberrypi/firmware/archive/${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="-* ~arm"
- S="${WORKDIR}/firmware-${PV}"
-fi
-
-RESTRICT="binchecks strip"
-
-pkg_preinst() {
- if [ -z "${REPLACING_VERSIONS}" ] ; then
- local msg=""
- if [ -e "${D}"/boot/cmdline.txt -a -e /boot/cmdline.txt ] ; then
- msg+="/boot/cmdline.txt "
- fi
- if [ -e "${D}"/boot/config.txt -a -e /boot/config.txt ] ; then
- msg+="/boot/config.txt "
- fi
- if [ -n "${msg}" ] ; then
- msg="This package installs following files: ${msg}."
- msg="${msg} Please remove(backup) your copies durning install"
- msg="${msg} and merge settings afterwards."
- msg="${msg} Further updates will be CONFIG_PROTECTed."
- die "${msg}"
- fi
- fi
-}
-
-src_install() {
- insinto /boot
- cd boot || die
- doins bootcode.bin fixup*.dat start*elf
- doins *.dtb
- doins -r overlays
- newins "${FILESDIR}"/${PN}-0_p20130711-config.txt config.txt
- newins "${FILESDIR}"/${PN}-0_p20130711-cmdline.txt cmdline.txt
- newenvd "${FILESDIR}"/${PN}-0_p20130711-envd 90${PN}
- readme.gentoo_create_doc
-}
-
-pkg_postinst() {
- readme.gentoo_print_elog
-}
-
-DOC_CONTENTS="Please configure your ram setup by editing /boot/config.txt"