summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/slixmpp/Manifest2
-rw-r--r--dev-python/slixmpp/files/slixmpp-1.7.1-fix-py3.10.patch28
-rw-r--r--dev-python/slixmpp/slixmpp-1.7.1.ebuild38
-rw-r--r--dev-python/slixmpp/slixmpp-1.8.0.1.ebuild36
4 files changed, 0 insertions, 104 deletions
diff --git a/dev-python/slixmpp/Manifest b/dev-python/slixmpp/Manifest
index a816fce8cb4e..93180e7a2c76 100644
--- a/dev-python/slixmpp/Manifest
+++ b/dev-python/slixmpp/Manifest
@@ -1,3 +1 @@
-DIST slixmpp-1.7.1.tar.gz 931753 BLAKE2B 3de14be36353bc5f5f2cfbe002c44c5e843a7b36fa31a9dd315e363fc67e36d080df0dc70d82e65c6802c41377c2e98f56ff4e23cc5e9a92165c3d3b7565493f SHA512 5a59fcbb901e6f4456049f1ec2bbf781b1ec7c5a3ad4b66216d4c5daffa7f0606f74b941647fe2b53e6c8cdc476371305c7b7a2ca24d21450e19548f888be3b1
-DIST slixmpp-1.8.0.1.tar.gz 532519 BLAKE2B c4cda06d1d16ef92404263a90a6abbba46e526b4f9edc54228757b73c9faa0f04e9340ea80b5f0491017bad04094512bd25fe04fc095742b639cecba73db058b SHA512 0bfa39f126f2154702e160117b619f41319362723226ebf0ed4b803aafef0302d4df9d9a4cff5fd890507a10ac7424a07cc3bece519451bd56be400998dc0178
DIST slixmpp-1.8.1.tar.gz 532622 BLAKE2B d0c12c240c8a14df0a0765f8bac02eb545951a0b9749ec9569d651caa3457af1a71f1c6b3a10db879fe25648b1c3c456b78e48042a83124b0a8d4d35df60134d SHA512 13b355592d564b7e211e6007fa19099e619480d0a87332b68163115852840ad2f0c70063b4260fc88d4da67e13ea97c88972fc05999c1870256b0de0257409f9
diff --git a/dev-python/slixmpp/files/slixmpp-1.7.1-fix-py3.10.patch b/dev-python/slixmpp/files/slixmpp-1.7.1-fix-py3.10.patch
deleted file mode 100644
index 0901090e4651..000000000000
--- a/dev-python/slixmpp/files/slixmpp-1.7.1-fix-py3.10.patch
+++ /dev/null
@@ -1,28 +0,0 @@
-From 8b7648502b003d433a08333b041baf1d4960c9d4 Mon Sep 17 00:00:00 2001
-From: Nicolas Cedilnik <nicoco@nicoco.fr>
-Date: Mon, 22 Feb 2021 13:07:15 +0100
-Subject: [PATCH] Fix deprecation warning
-
----
- slixmpp/thirdparty/orderedset.py | 4 ++--
- 1 file changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/slixmpp/thirdparty/orderedset.py b/slixmpp/thirdparty/orderedset.py
-index f6642db3..43023af4 100644
---- a/slixmpp/thirdparty/orderedset.py
-+++ b/slixmpp/thirdparty/orderedset.py
-@@ -20,9 +20,9 @@
- # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR
- # OTHER DEALINGS IN THE SOFTWARE.
-
--import collections
-+from collections.abc import MutableSet
-
--class OrderedSet(collections.MutableSet):
-+class OrderedSet(MutableSet):
-
- def __init__(self, iterable=None):
- self.end = end = []
---
-GitLab
-
diff --git a/dev-python/slixmpp/slixmpp-1.7.1.ebuild b/dev-python/slixmpp/slixmpp-1.7.1.ebuild
deleted file mode 100644
index e37f059d7d37..000000000000
--- a/dev-python/slixmpp/slixmpp-1.7.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python 3 library for XMPP"
-HOMEPAGE="https://lab.louiz.org/poezio/slixmpp"
-LICENSE="MIT"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="amd64"
-fi
-
-DEPEND="
- net-dns/libidn
-"
-RDEPEND="
- dev-python/aiodns[${PYTHON_USEDEP}]
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- ${DEPEND}
-"
-
-PATCHES=(
- "${FILESDIR}/${P}-fix-py3.10.patch"
-)
-
-distutils_enable_tests unittest
diff --git a/dev-python/slixmpp/slixmpp-1.8.0.1.ebuild b/dev-python/slixmpp/slixmpp-1.8.0.1.ebuild
deleted file mode 100644
index 1a7f67fcb5c6..000000000000
--- a/dev-python/slixmpp/slixmpp-1.8.0.1.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} )
-
-inherit distutils-r1
-
-DESCRIPTION="Python 3 library for XMPP"
-HOMEPAGE="https://lab.louiz.org/poezio/slixmpp"
-LICENSE="MIT"
-SLOT="0"
-
-if [[ "${PV}" == "9999" ]]; then
- EGIT_REPO_URI="https://lab.louiz.org/poezio/${PN}.git"
- inherit git-r3
-else
- SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
- KEYWORDS="~amd64"
-fi
-
-DEPEND="
- net-dns/libidn
-"
-RDEPEND="
- dev-python/aiodns[${PYTHON_USEDEP}]
- dev-python/aiohttp[${PYTHON_USEDEP}]
- dev-python/defusedxml[${PYTHON_USEDEP}]
- dev-python/pyasn1-modules[${PYTHON_USEDEP}]
- dev-python/pyasn1[${PYTHON_USEDEP}]
- ${DEPEND}
-"
-
-distutils_enable_tests unittest