summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--app-metrics/collectd/collectd-5.12.0.ebuild11
-rw-r--r--profiles/arch/amd64/package.use.mask4
-rw-r--r--profiles/arch/amd64/package.use.stable.mask5
-rw-r--r--profiles/arch/base/package.use.mask4
-rw-r--r--profiles/desc/collectd_plugins.desc1
5 files changed, 21 insertions, 4 deletions
diff --git a/app-metrics/collectd/collectd-5.12.0.ebuild b/app-metrics/collectd/collectd-5.12.0.ebuild
index e3d3fc157a4f..b4afd4d953e8 100644
--- a/app-metrics/collectd/collectd-5.12.0.ebuild
+++ b/app-metrics/collectd/collectd-5.12.0.ebuild
@@ -52,8 +52,8 @@ COLLECTD_TESTED_PLUGINS="aggregation amqp apache apcups ascent battery bind
buddyinfo capabilities ceph cgroups check_uptime chrony connectivity
conntrack contextswitch cpu cpufreq cpusleep csv curl curl_json
curl_xml dbi df disk dns drbd email entropy ethstat exec fhcount
- filecount fscache gmond gps hddtemp hugepages interface ipc ipmi
- iptables ipvs irq java lua load logfile logparser log_logstash
+ filecount fscache gmond gps gpu_nvidia hddtemp hugepages interface ipc
+ ipmi iptables ipvs irq java lua load logfile logparser log_logstash
madwifi match_empty_counter match_hashed match_regex match_timediff
match_value mbmon mcelog md memcachec memcached memory modbus mqtt
multimeter mysql netlink network network nfs nginx notify_desktop
@@ -101,6 +101,7 @@ COMMON_DEPEND="
collectd_plugins_dns? ( net-libs/libpcap )
collectd_plugins_gmond? ( sys-cluster/ganglia )
collectd_plugins_gps? ( sci-geosciences/gpsd:= )
+ collectd_plugins_gpu_nvidia? ( dev-util/nvidia-cuda-toolkit )
collectd_plugins_ipmi? ( >=sys-libs/openipmi-2.0.16-r1 )
collectd_plugins_iptables? ( >=net-firewall/iptables-1.4.13:0= )
collectd_plugins_log_logstash? ( dev-libs/yajl:= )
@@ -413,6 +414,12 @@ src_configure() {
use collectd_plugins_smart || myconf+=" --with-libatasmart=no"
use collectd_plugins_gps || myconf+=" --with-libgps=no"
+ if use collectd_plugins_gpu_nvidia; then
+ myconf+=" --with-cuda=${EPREFIX}/opt/cuda"
+ else
+ myconf+=" --with-cuda=no"
+ fi
+
if use perl; then
myconf+=" --with-perl-bindings=INSTALLDIRS=vendor"
else
diff --git a/profiles/arch/amd64/package.use.mask b/profiles/arch/amd64/package.use.mask
index 099a58aefbd7..6e4e7e3cd1a9 100644
--- a/profiles/arch/amd64/package.use.mask
+++ b/profiles/arch/amd64/package.use.mask
@@ -17,6 +17,10 @@
#--- END OF EXAMPLES ---
+# Thomas Deutschmann <whissi@gentoo.org> (2020-09-07)
+# dev-util/nvidia-cuda-toolkit is keyworded on amd64
+app-metrics/collectd -collectd_plugins_gpu_nvidia
+
# Thomas Deutschmann <whissi@gentoo.org> (2020-08-17)
# Columnstore engine is supported on amd64
dev-db/mariadb -columnstore
diff --git a/profiles/arch/amd64/package.use.stable.mask b/profiles/arch/amd64/package.use.stable.mask
index f55e89a559d5..0020c0a53bb4 100644
--- a/profiles/arch/amd64/package.use.stable.mask
+++ b/profiles/arch/amd64/package.use.stable.mask
@@ -17,9 +17,10 @@
#--- END OF EXAMPLES ---
-# Thomas Deutschmann <whissi@gentoo.org> (2020-08-05)
+# Thomas Deutschmann <whissi@gentoo.org> (2020-09-07)
# sys-cluster/slurm has no stable keywords
-app-metrics/collectd collectd_plugins_slurm
+# dev-util/nvidia-cuda-toolkit has no stable keywords
+app-metrics/collectd collectd_plugins_slurm collectd_plugins_gpu_nvidia
# Joonas Niilola <juippis@gentoo.org> (2020-06-21)
# sys-apps/apparmor doesn't have stable keywords.
diff --git a/profiles/arch/base/package.use.mask b/profiles/arch/base/package.use.mask
index dac55926b80b..e95a85a5d18a 100644
--- a/profiles/arch/base/package.use.mask
+++ b/profiles/arch/base/package.use.mask
@@ -1,6 +1,10 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
+# Thomas Deutschmann <whissi@gentoo.org> (2020-09-07)
+# dev-util/nvidia-cuda-toolkit is only available on amd64
+app-metrics/collectd collectd_plugins_gpu_nvidia
+
# Sam James <sam@gentoo.org> (2020-07-03)
# Rust is only available on some arches
# Bug #728558
diff --git a/profiles/desc/collectd_plugins.desc b/profiles/desc/collectd_plugins.desc
index ef2d2d9f415f..11d1b8eb96b3 100644
--- a/profiles/desc/collectd_plugins.desc
+++ b/profiles/desc/collectd_plugins.desc
@@ -41,6 +41,7 @@ filecount - Build the filecount input plugin (counts the number of files in a di
fscache - Build the fscache input plugin (collects information about the file-system based caching infrastructure for network file-systems and other slow media)
gmond - Build the gmond input plugin (receives data from gmond, the client daemon of the Ganglia project)
gps - Build the gps input plugin (collects number of satellites seen by a GPS receiver using sci-geosciences/gpsd)
+gpu_nvidia - Build the NVIDIA GPU input plugin (collects stats from NVIDIA GPU)
hddtemp - Build the hddtemp input plugin (collects the temperature of disks from hddtemp daemon)
hugepages - Build the hugepages input plugin (collects the number of used and free hugepages on Linux)
interface - Build the interface input plugin (collects information about the traffic, packets per second and errors of interfaces)