summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--www-misc/urlwatch/Manifest2
-rw-r--r--www-misc/urlwatch/urlwatch-2.13.ebuild58
-rw-r--r--www-misc/urlwatch/urlwatch-2.16.ebuild60
3 files changed, 0 insertions, 120 deletions
diff --git a/www-misc/urlwatch/Manifest b/www-misc/urlwatch/Manifest
index dd5ca5439a23..baa34b18c12f 100644
--- a/www-misc/urlwatch/Manifest
+++ b/www-misc/urlwatch/Manifest
@@ -1,3 +1 @@
-DIST urlwatch-2.13.tar.gz 34312 BLAKE2B 6ac618d4f1f78b0a3f6d17dd2283704e8d1fc7173ce6d79fcf0f9177f48463a610a4c20d8483a4a9c22e56eca67730ef25982981f310ca8e9927e48e298a1b1d SHA512 5ca6ad3de54c2e1d63cb545ae0d213a4483ef175dad947be00994bc990d047c7aec1f3b0a8b23290672db940001a9cc31c919aa7d9c280ab4792299e2dba684c
-DIST urlwatch-2.16.tar.gz 42713 BLAKE2B bee95c808b8705135112646ed7bf42c6606d716f447394e69fbc3355d38597e44b3e94ac91c6c2304fadcc5eb7d35349e6d54601721319c39268583fa8c7c042 SHA512 ffa9245bc4b8631e3105b1afd4ed3c3f5585bc30cd56c7531f9c2d0e4d61e36b56db3a69d62f851bed5fba9c9c332034b1757d70b32f4a4b0607ae59ed6cf887
DIST urlwatch-2.17.tar.gz 44178 BLAKE2B 46163b3305a50c3b5165da8f794c252aeb0a3581f16ba04cc1f0d920066accd02f7eba47718012e2ac0071f6bfa31019777a28840179a28a7fe365ae2e8f1d2c SHA512 635bca7e55641dd73447f5ec9ad429539decfaa8a1c19ab073c3bd46acfc518fa6012d855e0c37dd78654da28acf1446f580def611bcb85ae94fe13f567e3613
diff --git a/www-misc/urlwatch/urlwatch-2.13.ebuild b/www-misc/urlwatch/urlwatch-2.13.ebuild
deleted file mode 100644
index 59ec3ad5a552..000000000000
--- a/www-misc/urlwatch/urlwatch-2.13.ebuild
+++ /dev/null
@@ -1,58 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A tool for monitoring webpages for updates"
-HOMEPAGE="https://thp.io/2008/urlwatch/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/minidb[${PYTHON_USEDEP}]
- <dev-python/pyyaml-5[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pycodestyle[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CHANGELOG.md README.md )
-
-python_test() {
- nosetests test || die "tests failed with ${EPYTHON}"
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- if ! has_version dev-python/chump; then
- elog "Install 'dev-python/chump' to enable Pushover" \
- "notifications support"
- fi
- if ! has_version dev-python/pushbullet-py; then
- elog "Install 'dev-python/pushbullet-py' to enable" \
- "Pushbullet notifications support"
- fi
- elog "HTML parsing can be improved by installing one of the following packages"
- elog "and changing the html2text subfilter parameter:"
- elog "dev-python/beautifulsoup:4"
- elog "app-text/html2text"
- elog "dev-python/html2text"
- elog "www-client/lynx"
- fi
-}
diff --git a/www-misc/urlwatch/urlwatch-2.16.ebuild b/www-misc/urlwatch/urlwatch-2.16.ebuild
deleted file mode 100644
index c7dbf7344b2d..000000000000
--- a/www-misc/urlwatch/urlwatch-2.16.ebuild
+++ /dev/null
@@ -1,60 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-DESCRIPTION="A tool for monitoring webpages for updates"
-HOMEPAGE="https://thp.io/2008/urlwatch/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/appdirs[${PYTHON_USEDEP}]
- dev-python/cssselect[${PYTHON_USEDEP}]
- dev-python/keyring[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/minidb[${PYTHON_USEDEP}]
- <dev-python/pyyaml-5[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${RDEPEND}
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pycodestyle[${PYTHON_USEDEP}]
- )
-"
-
-DOCS=( CHANGELOG.md README.md )
-
-python_test() {
- nosetests -v test || die "tests failed with ${EPYTHON}"
-}
-
-pkg_postinst() {
- if [[ -z "${REPLACING_VERSIONS}" ]]; then
- if ! has_version dev-python/chump; then
- elog "Install 'dev-python/chump' to enable Pushover" \
- "notifications support"
- fi
- if ! has_version dev-python/pushbullet-py; then
- elog "Install 'dev-python/pushbullet-py' to enable" \
- "Pushbullet notifications support"
- fi
- elog "HTML parsing can be improved by installing one of the following packages"
- elog "and changing the html2text subfilter parameter:"
- elog "dev-python/beautifulsoup:4"
- elog "app-text/html2text"
- elog "dev-python/html2text"
- elog "www-client/lynx"
- fi
-}