summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/PyGithub/Manifest1
-rw-r--r--dev-python/PyGithub/PyGithub-1.59.1.ebuild38
2 files changed, 0 insertions, 39 deletions
diff --git a/dev-python/PyGithub/Manifest b/dev-python/PyGithub/Manifest
index ba42695c4ee1..6d9bf229258e 100644
--- a/dev-python/PyGithub/Manifest
+++ b/dev-python/PyGithub/Manifest
@@ -1,2 +1 @@
-DIST PyGithub-1.59.1.tar.gz 3295328 BLAKE2B 7a7dcfa49261aa7c6d7d3b252c77cc93bd24440858989ef2a8b257235ed7b101647c08532860f0fa21d1b8f2ac35541341df49a94c3495c7d9666fe7367738c1 SHA512 795c104253b250b11b539b526944776f70e947e23dc4b26fcdadb5de3dd3208a9b27c08ffdd14cade220fde3360b6993be7a028f0069ff60d99331048560faed
DIST PyGithub-2.1.1.tar.gz 3330531 BLAKE2B 9b288266379d7b1d85be91a7261596f9c98b97bdb5f17c4f8bb43b4765f07e2088f1130c802a623c875c8ddd7d31bdf3cad2a7fc6672ca50bb9a69c80bf4c907 SHA512 f5a0186c1a206cef070c6c19ae0cca5ab19993dd16b9df9997ba01a3fa02baee3425cef51588f7ac38636a165e36d9a5a2c4014e59482b583001c75efa7afc40
diff --git a/dev-python/PyGithub/PyGithub-1.59.1.ebuild b/dev-python/PyGithub/PyGithub-1.59.1.ebuild
deleted file mode 100644
index 97685ed6fe03..000000000000
--- a/dev-python/PyGithub/PyGithub-1.59.1.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYPI_NO_NORMALIZE=1
-PYTHON_COMPAT=( python3_{10..11} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="Python library to access the Github API v3"
-HOMEPAGE="
- https://github.com/PyGithub/PyGithub/
- https://pypi.org/project/PyGithub/
-"
-
-LICENSE="LGPL-3+"
-SLOT="0"
-KEYWORDS="amd64 x86"
-
-# cryptography via pyjwt[crypto]
-RDEPEND="
- dev-python/cryptography[${PYTHON_USEDEP}]
- dev-python/deprecated[${PYTHON_USEDEP}]
- >=dev-python/pyjwt-2.4.0[${PYTHON_USEDEP}]
- >=dev-python/pynacl-1.4.0[${PYTHON_USEDEP}]
- >=dev-python/requests-2.14.0[${PYTHON_USEDEP}]
- dev-python/six[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/setuptools-scm[${PYTHON_USEDEP}]
- test? (
- >=dev-python/httpretty-0.9.6[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest