summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-ml/ppxlib/Manifest1
-rw-r--r--dev-ml/ppxlib/ppxlib-0.30.0.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-ml/ppxlib/Manifest b/dev-ml/ppxlib/Manifest
index c6cbfb7aadb6..f71ce1255c64 100644
--- a/dev-ml/ppxlib/Manifest
+++ b/dev-ml/ppxlib/Manifest
@@ -8,3 +8,4 @@ DIST ppxlib-0.24.0.tar.gz 390297 BLAKE2B 7d8972b766cc8104a4d43aebc79e927e51cba11
DIST ppxlib-0.28.0.tar.gz 422105 BLAKE2B a88f6c0cba93c880bd3f6e29fdc152e45240a5eb170454ed540c01dc5b88648f1ac71071316f0282bdd4c55cc6bc57e10ac5a7b08004354f50ed0cb2334646bf SHA512 31290cd34f4b306f289b6ef78fbc5907f007c722ffc2cb0682c1944af954f2c6732b236891d1872a22b856d0aee0f7e84d3262ee103aff15d0a4dcd1a20bbfe6
DIST ppxlib-0.29.0.tar.gz 572842 BLAKE2B e772cfbbc5ff0390b1d256b7671e51aac0c86fe14e912e42fa6f428958d25af09920deae89ba080e37842f21361494237b697abe48dd563df9f69512a4a110ea SHA512 34babcea63b952ca610b5b9841a7d045e3973870014968d5abfff259de8d0f383e79f799fa3522830e0da5a7ff02fa52764b7cad64c8ac0da5a37f8897314c80
DIST ppxlib-0.29.1.tar.gz 543819 BLAKE2B b0d3920b2aaef887b0120ae66dfa3a0f83d4a4edb237390bddd5206084f77bbd8483d99bc422ce6411a9a1aca7de4fcc5f1f85f9cf46532b7e06c476f2b76b72 SHA512 9bfd52709a63399ff35697b442de6818e2a61b9a2ccf33638f2da6295e3e034e2ae6108a2b8567402e80d928636cdee1572cc14d228a47fbda50625219e411f9
+DIST ppxlib-0.30.0.tar.gz 573753 BLAKE2B f16ba3b01288a535ebf7842d8b9379061cc86cb1bad7841540855508d7d9c10c27e63456d68a16a2408a6eee5cffe82c3c0202ad7894b9fabad8194136762e30 SHA512 a7310c5c0fe76c72984bc6a27648bf12ac83222c029b91a7abf8be13f1950f84de4b24e28f2bb50a6a65c16c9a6bb8c4d3d0596c4b5f7f5bedba87f8ca55a810
diff --git a/dev-ml/ppxlib/ppxlib-0.30.0.ebuild b/dev-ml/ppxlib/ppxlib-0.30.0.ebuild
new file mode 100644
index 000000000000..5dcf6f546bc2
--- /dev/null
+++ b/dev-ml/ppxlib/ppxlib-0.30.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+# Note that new "major" versions may change which OCaml version they support
+# See:
+# https://github.com/ocaml-ppx/ppxlib/issues/243
+# https://github.com/ocaml-ppx/ppxlib/issues/232
+
+DESCRIPTION="Base library and tools for ppx rewriters"
+HOMEPAGE="https://github.com/ocaml-ppx/ppxlib"
+SRC_URI="https://github.com/ocaml-ppx/ppxlib/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-ml/ocaml-compiler-libs-0.11.0:=
+ >=dev-ml/ocaml-migrate-parsetree-2.2.0:=
+ dev-ml/sexplib0:=
+ dev-ml/stdlib-shims:=
+ >=dev-ml/ppx_derivers-1.2.1:=
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-ml/findlib:=
+ >=dev-ml/base-0.11.0:=
+ dev-ml/cinaps:=
+ dev-ml/re:=
+ >=dev-ml/stdio-0.11.0:=
+ )
+"
+BDEPEND=">=dev-ml/dune-2.8"