summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/accessible-pygments/Manifest1
-rw-r--r--dev-python/accessible-pygments/accessible-pygments-0.0.5.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/accessible-pygments/Manifest b/dev-python/accessible-pygments/Manifest
index c3f6487d5040..783a4e37143d 100644
--- a/dev-python/accessible-pygments/Manifest
+++ b/dev-python/accessible-pygments/Manifest
@@ -1 +1,2 @@
DIST accessible-pygments-0.0.4.gh.tar.gz 4540933 BLAKE2B 1fdd376b9f069590552632a806f161404aeb3ae0c9b522705ea64476bccc97e3f888af270fba5e05680bb87e2d3283f2c93259c687e137efc56a38ca4d71b507 SHA512 b45b3c17bcfb2d66d397ee7e535c35159ab79080163f8ace286d73ea65a08f7e39c757414755d7f59bdae22a52198e26546ae61893bd9cd5c901d2e2b1efb2b1
+DIST accessible-pygments-0.0.5.gh.tar.gz 2273172 BLAKE2B ed07ecb1ef0d6dcc2b02383d1620c373bb54c65522752404a0e2e2382e374d35c11d7ad6978889b4fd20d4536b38d5ea951a2e6366725279123f5357ecff8a0a SHA512 2f5984c4f95a13dc566a0f916168fb293332f175da61f88ef7dcbc9f2bfcd8781d891b7830ed401839eef09ad65f7cbf94bb5a153bc5b4454ddf4c28573948d2
diff --git a/dev-python/accessible-pygments/accessible-pygments-0.0.5.ebuild b/dev-python/accessible-pygments/accessible-pygments-0.0.5.ebuild
new file mode 100644
index 000000000000..30ce5a7b1367
--- /dev/null
+++ b/dev-python/accessible-pygments/accessible-pygments-0.0.5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="A collection of accessible pygments styles"
+HOMEPAGE="
+ https://pypi.org/project/accessible-pygments/
+ https://github.com/Quansight-Labs/accessible-pygments/
+"
+# no tests in sdist, as of 0.0.5
+SRC_URI="
+ https://github.com/Quansight-Labs/accessible-pygments/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/pygments-1.5[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-fancy-pypi-readme[${PYTHON_USEDEP}]
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}