summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/smmap/Manifest1
-rw-r--r--dev-python/smmap/smmap-3.0.5.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/smmap/Manifest b/dev-python/smmap/Manifest
index 449866347cdc..4a537cdf8fa8 100644
--- a/dev-python/smmap/Manifest
+++ b/dev-python/smmap/Manifest
@@ -1 +1,2 @@
DIST smmap-3.0.4.tar.gz 22459 BLAKE2B daccd2cfa4d448297d1a0b2c33c1a316e8c84ae5dbe934d688fbdf034a660214c98d428206b8e9ce1cab3e5f3561309a1e7f29e3371b7358954f0fe7ea37092d SHA512 da7e5c0257f29b487eb5ee18f29656340f7f6999dd625d93560444d526df8036a8fc4452242a2d01203907798709d82a0015709e097bc22acd3d0a8b976ef9fe
+DIST smmap-3.0.5.tar.gz 23228 BLAKE2B ccc36c33e9239f69a41eff291dcde7e455a84d886c2b087464b1b084ad8506b9d0f862b083635d51465089564edbd27ed0b7c9c5a0d1e58605b3db6f84dea857 SHA512 82d0167ba439164b5b9e6ca6081558b7f32af364f7935aa40500b34ca80e0fcf8d014e53eb2963e189d28ef18c8dd48da0b515392d149608fc3179fae3f69ee1
diff --git a/dev-python/smmap/smmap-3.0.5.ebuild b/dev-python/smmap/smmap-3.0.5.ebuild
new file mode 100644
index 000000000000..c3e03ccc7752
--- /dev/null
+++ b/dev-python/smmap/smmap-3.0.5.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="A pure Python implementation of a sliding window memory map manager"
+HOMEPAGE="
+ https://pypi.org/project/smmap/
+ https://github.com/gitpython-developers/smmap/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm64 ~x86"
+SLOT="0"
+
+distutils_enable_tests unittest