summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-util/rats/Manifest1
-rw-r--r--dev-util/rats/files/rats-2.1-add-getopt-trailing-null.patch11
-rw-r--r--dev-util/rats/files/rats-2.1-fix-null-pointers.patch128
-rw-r--r--dev-util/rats/rats-2.1-r2.ebuild36
4 files changed, 0 insertions, 176 deletions
diff --git a/dev-util/rats/Manifest b/dev-util/rats/Manifest
index 6ce3ff736460..3202b2edd529 100644
--- a/dev-util/rats/Manifest
+++ b/dev-util/rats/Manifest
@@ -1,2 +1 @@
-DIST rats-2.1.tar.gz 326930 BLAKE2B 4fa47cf69ab1b04ccf42b300fc55da386a9b5ac783517ec2efcfb545aba2cf27cc1b2a11d5d0d003cc8a0a5112a0cd1183f263c77a62f280268d214bc9ce7634 SHA512 2fdb670dc9559c453a6c69ee2d411e2626c0ee4cca4b59ceda878142008e136dfd11f8265c0719383212b38b0358a9cab1a29f1cc92a986fc800dd0c46bdf0d3
DIST rats-2.4.tgz 393114 BLAKE2B 73dfefc42cd99420edba9ac28d56b51e058b144d9deaf9f1e322e7fe4331e16d05cff049efccd344723fe1634c3691f911dd71001671058c5912f84cfdc0bdbb SHA512 f402717fc935a2f9c2464e1623807575044258fd998cabc8f115c063141004b5978bad739021f109cbbd1abd84231155eb59671ae202aefb40e1fd6733d8ac6d
diff --git a/dev-util/rats/files/rats-2.1-add-getopt-trailing-null.patch b/dev-util/rats/files/rats-2.1-add-getopt-trailing-null.patch
deleted file mode 100644
index 65ea6df1f456..000000000000
--- a/dev-util/rats/files/rats-2.1-add-getopt-trailing-null.patch
+++ /dev/null
@@ -1,11 +0,0 @@
-diff -Nuar --exclude '*~' rats-2.1.orig/main.c rats-2.1/main.c
---- rats-2.1.orig/main.c 2002-09-16 21:05:43.000000000 -0700
-+++ rats-2.1/main.c 2006-05-21 21:56:29.578601459 -0700
-@@ -278,6 +278,7 @@
- {"columns", 0,0,0},
- {"context", 0,0,0},
- {"all-static", 0,0,0},
-+ {NULL,0,0,0}
- };
- progname = argv[0];
- flags|=RECURSIVE_FILE_SCAN;
diff --git a/dev-util/rats/files/rats-2.1-fix-null-pointers.patch b/dev-util/rats/files/rats-2.1-fix-null-pointers.patch
deleted file mode 100644
index 0d4c701f0bfc..000000000000
--- a/dev-util/rats/files/rats-2.1-fix-null-pointers.patch
+++ /dev/null
@@ -1,128 +0,0 @@
-diff -Nuar rats-2.1.orig/report.c rats-2.1/report.c
---- rats-2.1.orig/report.c 2002-09-16 21:05:43.000000000 -0700
-+++ rats-2.1/report.c 2006-05-21 23:16:16.323046789 -0700
-@@ -122,9 +122,15 @@
- return result;
- }
-
--
--
--
-+/* Exclusively for debugging vulnerabilities.
-+ * - robbat2@gentoo.org 21/05/2006 */
-+static void debug_vuln_dump(vulnerability_t *ptr) {
-+ fprintf(stderr,"vuln_dump: this=%x f=%s l=%d c=%d d=%x t=%d s=%d u=%x p=(%x,%x)\n",
-+ ptr,
-+ ptr->filename,ptr->lineno,ptr->column,
-+ ptr->data,ptr->type,ptr->severity,
-+ ptr->uses,ptr->next,ptr->prev);
-+}
-
- static void
- replace_cfname(char *filename)
-@@ -317,6 +323,27 @@
- insert_vulnerability(log);
- }
-
-+/* These are special static vulnerabilities because we don't
-+ * want NULL data elements in the vulnerability_t->data
-+ * field, because the HTML and XML output formats use that
-+ * pointer without checking it for being null first.
-+ * - robbat2@gentoo.org 21/05/2006 */
-+static struct Vuln_t vuln_PerlBacktick = {
-+ .Name = "Perl Backtick"
-+};
-+static struct Vuln_t vuln_PhpBacktick = {
-+ .Name = "PHP Backtick"
-+};
-+static struct Vuln_t vuln_PythonBacktick = {
-+ .Name = "Python Backtick"
-+};
-+static struct Vuln_t vuln_StaticLocalBuffer = {
-+ .Name = "Static Local Buffer"
-+};
-+static struct Vuln_t vuln_StaticGlobalBuffer = {
-+ .Name = "Static Global Buffer"
-+};
-+
- void log_perlbacktick(int lineno, int column, Severity_t severity)
- {
- vulnerability_t * log;
-@@ -325,7 +352,7 @@
- log->filename = current_file;
- log->column = column;
- log->lineno = lineno;
-- log->data = (Vuln_t *)NULL;
-+ log->data = &vuln_PerlBacktick;
- log->type = PerlBacktick;
- log->severity = severity;
- log->uses = (toctou_use_t *)NULL;
-@@ -342,7 +369,7 @@
- log->filename = current_file;
- log->column = column;
- log->lineno = lineno;
-- log->data = (Vuln_t *)NULL;
-+ log->data = &vuln_PhpBacktick;
- log->type = PhpBacktick;
- log->severity = severity;
- log->uses = (toctou_use_t *)NULL;
-@@ -358,7 +385,7 @@
- log->filename = current_file;
- log->column = column;
- log->lineno = lineno;
-- log->data = (Vuln_t *)NULL;
-+ log->data = &vuln_PythonBacktick;
- log->type = PythonBacktick;
- log->severity = severity;
- log->uses = (toctou_use_t *)NULL;
-@@ -374,7 +401,16 @@
- log->filename = current_file;
- log->column = column;
- log->lineno = lineno;
-- log->data = (Vuln_t *)NULL;
-+ switch(type) {
-+ case StaticLocalBuffer:
-+ log->data = &vuln_StaticLocalBuffer;
-+ break;
-+ case StaticGlobalBuffer:
-+ log->data = &vuln_StaticGlobalBuffer;
-+ break;
-+ default:
-+ log->data = (Vuln_t *)NULL;
-+ }
- log->type = type;
- log->severity = severity;
- log->uses = (toctou_use_t *)NULL;
-@@ -432,6 +468,10 @@
- static void build_xml_vulnerability(vulnerability_t *ptr) {
- int i;
-
-+ /* Debugging - robbat2@gentoo.org 21/05/2006 */
-+ if(ptr->data == NULL)
-+ debug_vuln_dump(ptr);
-+
- printf("<vulnerability>\n");
-
- /* Output the severity */
-@@ -593,6 +633,8 @@
- void report_vulnerability(vulnerability_t *ptr)
- {
- int i;
-+ if(ptr->data == NULL)
-+ debug_vuln_dump(ptr);
-
- switch (ptr->type)
- {
-@@ -890,8 +932,10 @@
-
- static void build_html_vulnerability(vulnerability_t *ptr) {
- int i;
--
--
-+
-+ /* Debugging - robbat2@gentoo.org 21/05/2006 */
-+ if(ptr->data == NULL)
-+ debug_vuln_dump(ptr);
-
- /* Output the severity */
- printf(" <b>Severity: %s</b><br/>\n",
diff --git a/dev-util/rats/rats-2.1-r2.ebuild b/dev-util/rats/rats-2.1-r2.ebuild
deleted file mode 100644
index 161aeea514e1..000000000000
--- a/dev-util/rats/rats-2.1-r2.ebuild
+++ /dev/null
@@ -1,36 +0,0 @@
-# Copyright 1999-2011 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=3
-inherit eutils
-
-DESCRIPTION="RATS - Rough Auditing Tool for Security"
-HOMEPAGE="http://www.fortifysoftware.com/security-resources/rats.jsp"
-SRC_URI="http://www.fortifysoftware.com/servlet/downloads/public/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos"
-IUSE=""
-
-DEPEND="dev-libs/expat"
-
-src_prepare() {
- epatch "${FILESDIR}"/${P}-add-getopt-trailing-null.patch
- epatch "${FILESDIR}"/${P}-fix-null-pointers.patch
-}
-
-src_configure() {
- econf --datadir="${EPREFIX}/usr/share/${PN}/"
-}
-
-src_install () {
- einstall SHAREDIR="${ED}/usr/share/${PN}" MANDIR="${ED}/usr/share/man"
- dodoc README README.win32
-}
-
-pkg_postinst() {
- ewarn "Please be careful when using this program with it's force language"
- ewarn "option, '--language <LANG>' it may take huge amounts of memory when"
- ewarn "it tries to treat binary files as some other type."
-}