summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gui-libs/gtk-layer-shell/Manifest1
-rw-r--r--gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.1.ebuild57
2 files changed, 0 insertions, 58 deletions
diff --git a/gui-libs/gtk-layer-shell/Manifest b/gui-libs/gtk-layer-shell/Manifest
index 696351ae0c09..21064712c5a4 100644
--- a/gui-libs/gtk-layer-shell/Manifest
+++ b/gui-libs/gtk-layer-shell/Manifest
@@ -1,2 +1 @@
-DIST gtk-layer-shell-0.8.1.tar.gz 136156 BLAKE2B 19c16d49d119572b0a3ef9bf0aee2341dedb4b2e5afedee16b9817e16fcd2adba7696a9d6f2f01b4ebaa3636c116d8977079a9b83ed1941f9d97df9389425780 SHA512 070673a73166c9fd0ea10e6aa98c480318fbf8a6c2dff2a9b4900aea40bb59680d41d9bba9917953fabe4358c0dfa6c3d0221c579ada37cee72ce23433b40329
DIST gtk-layer-shell-0.8.2.tar.gz 137693 BLAKE2B 8c36e37fe0e675bfa9f3bfb6c4013ac7b137d27615cb29bd750c4cbbff36754986d0608cb97e427972e9108b048b6bca5611e89c01275aabec05c0b1fc9b7e62 SHA512 e3b56612dab2527d5242b8305362c88100de3eac76cee32ce51791cbc77df38a5052143bf4bf5781a90fa62e026a758ef9d10dc5b4292b0b334983842fad632c
diff --git a/gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.1.ebuild b/gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.1.ebuild
deleted file mode 100644
index 02e8dcbdac99..000000000000
--- a/gui-libs/gtk-layer-shell/gtk-layer-shell-0.8.1.ebuild
+++ /dev/null
@@ -1,57 +0,0 @@
-# Copyright 2020-2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-PYTHON_COMPAT=( python3_{9..11} )
-VALA_USE_DEPEND="vapigen"
-inherit vala meson python-any-r1
-
-if [[ ${PV} == 9999 ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://github.com/wmww/${PN}"
-else
- SRC_URI="https://github.com/wmww/${PN}/archive/refs/tags/v${PV}.tar.gz -> ${P}.tar.gz"
- KEYWORDS="~alpha amd64 arm arm64 ~ia64 ~loong ~mips ppc ppc64 ~riscv ~sparc x86"
-fi
-
-DESCRIPTION="Library to create desktop components for Wayland using the Layer Shell protocol"
-HOMEPAGE="https://github.com/wmww/gtk-layer-shell"
-
-LICENSE="MIT LGPL-3+"
-SLOT="0"
-IUSE="examples gtk-doc introspection test vala"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="vala? ( introspection )"
-
-DEPEND="
- >=x11-libs/gtk+-3.24.37:3[introspection?,wayland]
- >=dev-libs/wayland-1.10.0
- >=dev-libs/wayland-protocols-1.16
-"
-RDEPEND="${DEPEND}"
-BDEPEND="
- dev-util/wayland-scanner
- virtual/pkgconfig
- x11-base/xorg-proto
- gtk-doc? ( dev-util/gtk-doc )
- test? ( ${PYTHON_DEPS} )
- vala? ( $(vala_depend) )
-"
-
-src_prepare() {
- default
- use vala && vala_setup
-}
-
-src_configure() {
- local emesonargs=(
- $(meson_use examples)
- $(meson_use gtk-doc docs)
- $(meson_use test tests)
- $(meson_use introspection)
- $(meson_use vala vapi)
- )
- meson_src_configure
-}