summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/pytest/Manifest1
-rw-r--r--dev-python/pytest/pytest-5.3.4.ebuild66
2 files changed, 67 insertions, 0 deletions
diff --git a/dev-python/pytest/Manifest b/dev-python/pytest/Manifest
index c14396024043..27b5c2045121 100644
--- a/dev-python/pytest/Manifest
+++ b/dev-python/pytest/Manifest
@@ -4,3 +4,4 @@ DIST pytest-4.6.8.tar.gz 956062 BLAKE2B f28e3226c7dfe4188168cfdf9623c96d0b274a24
DIST pytest-4.6.9.tar.gz 956816 BLAKE2B 7eaeaa0d47c17836a35d9cdc97663f8ef65253099b21d60a7ffc3655d8bd93c6b4e33045caa6c8ab9bb8b920b93e596ba86d8eac4ab07b3b7a5989b38312f4fc SHA512 ab45a8662aa798a6ae224ad2cd68e043c605e4830c76cb6c6aca3cfccef232c024cbbb6c48c9bae19148099c339abfef3270a2208cc7e5c37a10b34b0aa6ba79
DIST pytest-5.3.2.tar.gz 995560 BLAKE2B aaea9d89e884a82056eeea3068c70604c73d50c96b8d78c6ee14c67bbe066f0e6d882c1b8f95539a2338d6739e047680d901a9db108b1923fa4d3d03dc3f2115 SHA512 2ab39973848d2d4693edd1dbd7ab2798b574026c9277bddd4a18e57aec65b3d93de201e87f58eb26030183b5c71818e6e56bcc1cda8c50892546cb1c04d6984a
DIST pytest-5.3.3.tar.gz 990948 BLAKE2B fed1d9386aeec587134ac2057348cf59cf554a0fb3d4ff7251917662eb52e914021d17890adc58fb40f06382e770f0e22c2db8abdd0d27a2005f187daf1eaa7f SHA512 79ac431f6a965d00431d3fa8353c756166d88628acfc254225f495bae9ca5f9e78a0282156a1e523b044a18da5fec9925a1a2aab5fcda3bac39cdaf2dee7be36
+DIST pytest-5.3.4.tar.gz 990897 BLAKE2B dd6f0a277352dd72e6348e89813a7df50aabf9ee134afd69412100b87a7898128ec6b17bf29082c88554b66ba5622b7e0b9a1338d6b740795f33055a9279cfdc SHA512 562966d74d2ff12715ececa46acdd49de67f5e792687d52b3f53589f6dc6105aed09bd4c5098989d70b8a69e6bb4cfb9c0b1ee7e9cfc8e8252e3ba6b4d39e4bc
diff --git a/dev-python/pytest/pytest-5.3.4.ebuild b/dev-python/pytest/pytest-5.3.4.ebuild
new file mode 100644
index 000000000000..1be7d663ccd2
--- /dev/null
+++ b/dev-python/pytest/pytest-5.3.4.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Simple powerful testing with Python"
+HOMEPAGE="https://pytest.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# When bumping, please check setup.py for the proper py version
+PY_VER="1.5.0"
+
+# pathlib2 has been added to stdlib before py3.6, but pytest needs __fspath__
+# support, which only came in py3.6.
+RDEPEND="
+ >=dev-python/attrs-17.4.0[${PYTHON_USEDEP}]
+ dev-python/importlib_metadata[${PYTHON_USEDEP}]
+ >=dev-python/more-itertools-4.0.0[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/pluggy-0.12[${PYTHON_USEDEP}]
+ <dev-python/pluggy-1
+ >=dev-python/py-${PY_VER}[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/wcwidth[${PYTHON_USEDEP}]
+ virtual/python-funcsigs[${PYTHON_USEDEP}]"
+
+# flake cause a number of tests to fail
+DEPEND="${RDEPEND}
+ test? (
+ >=dev-python/hypothesis-3.56[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/xmlschema[${PYTHON_USEDEP}]
+ !!dev-python/flaky
+ )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}"-4.5.0-strip-setuptools_scm.patch
+)
+
+python_prepare_all() {
+ grep -qF "py>=${PY_VER}" setup.py || die "Incorrect dev-python/py dependency"
+
+ # Something in the ebuild environment causes this to hang/error.
+ # https://bugs.gentoo.org/598442
+ rm testing/test_pdb.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ "${EPYTHON}" -m pytest -vv --lsof -rfsxX \
+ || die "tests failed with ${EPYTHON}"
+}