summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/rich/Manifest1
-rw-r--r--dev-python/rich/files/rich-13.7.0-nocolor.patch51
-rw-r--r--dev-python/rich/rich-13.7.0.ebuild62
3 files changed, 0 insertions, 114 deletions
diff --git a/dev-python/rich/Manifest b/dev-python/rich/Manifest
index e4b222bb1782..f37f2db2d0c5 100644
--- a/dev-python/rich/Manifest
+++ b/dev-python/rich/Manifest
@@ -1,3 +1,2 @@
DIST rich-13.4.2.gh.tar.gz 15063000 BLAKE2B f65079440bc7d89a3ff03be01fa71e076493ae50f22ae8781be2448a7ff2769c174d6654db3a835d34720c34cd8cbecfdd6b13e3064cf7fdcade71806563309d SHA512 17052a9fb0e1d89b31a00d8a719214719891d048fd805185b2d4258c8766130f44bf2280c9567bc162f3b34d9bf2eb7d747d6a37d910c81cd53d3003b51f70bd
-DIST rich-13.7.0.gh.tar.gz 15057791 BLAKE2B d474b5817c0e64143313a1d0b66ef0953990196ecef6b0fd62d82828902008fa7293290c7f43c605a0c897ecebecb84e816583da8921cd31fc56c902ead2f5c9 SHA512 c5c432bd73b0c28d9585bce2e122d6b9da0a0744ea7824b4682948f11e153dfc615f5ed94d9531ced422298d352371fba5f25ddf16ca7a1d669f799ab361d984
DIST rich-13.7.1.gh.tar.gz 15058064 BLAKE2B 6fad18bf0a4e4f72e530c78db7a498f27dd8c9a7b9b17ca5ef12a94bbe513857f3c42d4903f8ebbfe8907727cddaf290f08862c27efb29db8aaf70c7bcb13ace SHA512 0c69101bc6c2a238a4c516812cda08299115b903b8282ee348b45b212a88fcbfbf69d11a3705a97bdb6192988ee3047804bb5b52b7950d860542cde8ce2d4bd2
diff --git a/dev-python/rich/files/rich-13.7.0-nocolor.patch b/dev-python/rich/files/rich-13.7.0-nocolor.patch
deleted file mode 100644
index 77aafa8294d1..000000000000
--- a/dev-python/rich/files/rich-13.7.0-nocolor.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-From 7d79acbabf3d9836a4bd9e7296d6f6dd6a222fb7 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
-Date: Sat, 9 Dec 2023 15:25:21 +0100
-Subject: [PATCH] Fix running tests in environment with FORCE_COLOR or NO_COLOR
- set
-
-Ensure to unset FORCE_COLOR and NO_COLOR environment variables within
-the scope of individual tests, in order to fix test failures when these
-variables are set in the environment where tests are run, e.g. via:
-
- NO_COLOR=1 tox
----
- CHANGELOG.md | 6 ++++++
- tests/conftest.py | 8 ++++++++
- 2 files changed, 14 insertions(+)
- create mode 100644 tests/conftest.py
-
-diff --git a/CHANGELOG.md b/CHANGELOG.md
-index 9b0eecd7..af7354b4 100644
---- a/CHANGELOG.md
-+++ b/CHANGELOG.md
-@@ -5,6 +5,12 @@ All notable changes to this project will be documented in this file.
- The format is based on [Keep a Changelog](https://keepachangelog.com/en/1.0.0/),
- and this project adheres to [Semantic Versioning](https://semver.org/spec/v2.0.0.html).
-
-+## Unreleased
-+
-+### Fixed
-+
-+- Running tests in environment with `FORCE_COLOR` or `NO_COLOR` environment variables
-+
- ## [13.7.0] - 2023-11-15
-
- ### Added
-diff --git a/tests/conftest.py b/tests/conftest.py
-new file mode 100644
-index 00000000..52662964
---- /dev/null
-+++ b/tests/conftest.py
-@@ -0,0 +1,8 @@
-+import pytest
-+
-+
-+@pytest.fixture(autouse=True)
-+def reset_color_envvars(monkeypatch):
-+ """Remove color-related envvars to fix test output"""
-+ monkeypatch.delenv("FORCE_COLOR", raising=False)
-+ monkeypatch.delenv("NO_COLOR", raising=False)
---
-2.43.0
-
diff --git a/dev-python/rich/rich-13.7.0.ebuild b/dev-python/rich/rich-13.7.0.ebuild
deleted file mode 100644
index 4e4bcc1af9e8..000000000000
--- a/dev-python/rich/rich-13.7.0.ebuild
+++ /dev/null
@@ -1,62 +0,0 @@
-# Copyright 2022-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=poetry
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
-
-inherit distutils-r1 optfeature
-
-DESCRIPTION="Python library for rendering rich text, tables, etc. to the terminal"
-HOMEPAGE="
- https://github.com/Textualize/rich/
- https://pypi.org/project/rich/
-"
-SRC_URI="
- https://github.com/Textualize/rich/archive/v${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- dev-python/colorama[${PYTHON_USEDEP}]
- >=dev-python/markdown-it-py-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/pygments-2.13.0[${PYTHON_USEDEP}]
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- # https://github.com/Textualize/rich/pull/3226
- "${FILESDIR}/${P}-nocolor.patch"
-)
-
-python_test() {
- local EPYTEST_DESELECT=(
- # TODO
- tests/test_console.py::test_size_can_fall_back_to_std_descriptors
- # TODO: segfault in recursion (PyQt6 interfering?)
- tests/test_traceback.py::test_recursive
- )
- # version-specific output -- the usual deal
- case ${EPYTHON} in
- pypy3)
- EPYTEST_DESELECT+=(
- # pypy3.10, to be more precise
- tests/test_inspect.py::test_inspect_integer_with_methods_python310only
- )
- ;;
- esac
-
- local -x COLUMNS=80
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- epytest
-}
-
-pkg_postinst() {
- optfeature "integration with HTML widgets for Jupyter" dev-python/ipywidgets
-}