summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--dev-python/sphinx-gallery/Manifest1
-rw-r--r--dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild41
2 files changed, 0 insertions, 42 deletions
diff --git a/dev-python/sphinx-gallery/Manifest b/dev-python/sphinx-gallery/Manifest
index 19f361b7c908..3ba64540a9a5 100644
--- a/dev-python/sphinx-gallery/Manifest
+++ b/dev-python/sphinx-gallery/Manifest
@@ -1,2 +1 @@
DIST sphinx-gallery-0.1.12.tar.gz 68976 BLAKE2B c9f8f12f775df8cac0f0ad7d70b0dd099dacb3b005584d1bbc878437443144d7e2613ceecd25cd4b0c8941818c5596f6435c1fa223b1e5c5d5196827a69163fb SHA512 57e8fc3746c2f5c941ddc3e00c749a6bfa63fb5741b3e5551df02f798858c417acee05a6b35512506aa0c4866b14a093cb4269284501672c3bbbf2edfc1edc1d
-DIST sphinx-gallery-0.1.7.tar.gz 59166 BLAKE2B d7deec8ddcd8d5a8e6496c7b7aa2a6ea4098441d9bdbde16c94c06547d659c30b26017190cdde29226a8147200f81f85977ff742372566a9c0b159beda1fd885 SHA512 0c14d35ed07db3988c9f119037676752e3f793a74000d7397f49e5b749a96db77ff4ba2e9ceb12993650e0c81042899a5056f3181e5360a738a5c62259c58ff5
diff --git a/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild b/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild
deleted file mode 100644
index 333d76c55a7a..000000000000
--- a/dev-python/sphinx-gallery/sphinx-gallery-0.1.7-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Sphinx extension to automatically generate an examples gallery"
-HOMEPAGE="http://sphinx-gallery.readthedocs.io/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="
- dev-python/matplotlib[${PYTHON_USEDEP}]
- dev-python/pillow[${PYTHON_USEDEP}]
- dev-python/sphinx[${PYTHON_USEDEP}]
-"
-# yes nose is somehow required besides testing
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( >=dev-python/nose-1.0[${PYTHON_USEDEP}] )
-"
-
-python_prepare_all() {
- # Remove setup_requires=['nose']
- sed -i -e /setup_requires/d setup.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- echo 'backend: agg' > matplotlibrc
- VARTEXFONTS="${T}"/fonts MPLCONFIGDIR="${BUILD_DIR}" \
- nosetests -v || die
-}